summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2022-11-03 23:30:08 (GMT)
committerGitHub <noreply@github.com>2022-11-03 23:30:08 (GMT)
commit018f093c096cca8b3965eb17afa01f5637317995 (patch)
tree6bd8c321decf7e544dd2dbf86976c51dc8407e92 /configure.ac
parent40a0e3c7b5b30912ddbe4cf58f289575d63fef12 (diff)
downloadhdf5-018f093c096cca8b3965eb17afa01f5637317995.zip
hdf5-018f093c096cca8b3965eb17afa01f5637317995.tar.gz
hdf5-018f093c096cca8b3965eb17afa01f5637317995.tar.bz2
Removes the memory allocation sanity checks feature (#2218)
* Removes the memory allocation sanity checks feature * Committing clang-format changes * Removes zero size checks for H5MM_(c|m)alloc() * Explicitly return NULL when size == 0 in H5allocate_memory() * Committing clang-format changes * Format fix Co-authored-by: github-actions <41898282+github-actions[bot]@users.noreply.github.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac46
1 files changed, 0 insertions, 46 deletions
diff --git a/configure.ac b/configure.ac
index c52be91..fed9ca7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2657,8 +2657,6 @@ AC_ARG_ENABLE([using-memchecker],
library. Enabling this causes the library to be
more picky about its memory operations and also
disables the library's free space manager code.
- This option is orthogonal to the
- --enable-memory-alloc-sanity-check option.
[default=no]
])],
[USINGMEMCHECKER=$enableval])
@@ -2688,50 +2686,6 @@ case "X-$USINGMEMCHECKER" in
;;
esac
-## ----------------------------------------------------------------------
-## Check if they would like to enable the internal memory allocation sanity
-## checking code.
-##
-AC_MSG_CHECKING([whether internal memory allocation sanity checking is used])
-AC_ARG_ENABLE([memory-alloc-sanity-check],
- [AS_HELP_STRING([--enable-memory-alloc-sanity-check],
- [Enable this option to turn on internal memory
- allocation sanity checking. This could cause
- more memory use and somewhat slower allocation.
- This option may also cause issues with HDF5
- filter plugins, so should not be enabled if
- filters are to be used. This option is orthogonal
- to the --enable-using-memchecker option.
- [default=no]
- ])],
- [MEMORYALLOCSANITYCHECK=$enableval])
-
-## Allow this variable to be substituted in
-## other files (src/libhdf5.settings.in, etc.)
-AC_SUBST([MEMORYALLOCSANITYCHECK])
-
-## Set default
-if test "X-$MEMORYALLOCSANITYCHECK" = X- ; then
-# Should consider enabling this option by default for
-# 'developer' builds if that build mode is added in
-# the future
- MEMORYALLOCSANITYCHECK=no
-fi
-
-case "X-$MEMORYALLOCSANITYCHECK" in
- X-yes)
- AC_DEFINE([MEMORY_ALLOC_SANITY_CHECK], [1],
- [Define to enable internal memory allocation sanity checking.])
- AC_MSG_RESULT([yes])
- ;;
- X-no)
- AC_MSG_RESULT([no])
- ;;
- *)
- AC_MSG_ERROR([Unrecognized value: $MEMORYALLOCSANITYCHECK])
- ;;
-esac
-
## Checkpoint the cache
AC_CACHE_SAVE