summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2022-11-09 19:06:26 (GMT)
committerGitHub <noreply@github.com>2022-11-09 19:06:26 (GMT)
commitd93c6fae4313c497ca1383d1aef24203a29b5087 (patch)
tree3c91e02d3d64182a726eaf68fe8ce28e63ecf5d0 /configure.ac
parent18c438bdf0be8ad98f968bb77b327d7a3f17a3f5 (diff)
downloadhdf5-d93c6fae4313c497ca1383d1aef24203a29b5087.zip
hdf5-d93c6fae4313c497ca1383d1aef24203a29b5087.tar.gz
hdf5-d93c6fae4313c497ca1383d1aef24203a29b5087.tar.bz2
Removes MPE instrumentation support. (#2245)
* Removes MPE instrumentation support. The Autotools will no longer accept --with-mpe= and the logging commands have been removed from the FUNC_ENTER macros. CMake has never supported instrumenting for MPE. * Committing clang-format changes Co-authored-by: github-actions <41898282+github-actions[bot]@users.noreply.github.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac64
1 files changed, 0 insertions, 64 deletions
diff --git a/configure.ac b/configure.ac
index c12c0f2..eea7537 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2682,7 +2682,6 @@ esac
## build also needs to have values defined.
##
AC_SUBST([ADD_PARALLEL_FILES]) ADD_PARALLEL_FILES="no"
-AC_SUBST([MPE]) MPE=no
AC_SUBST([INSTRUMENT_LIBRARY]) INSTRUMENT_LIBRARY=no
AC_SUBST([PARALLEL_FILTERED_WRITES])
AC_SUBST([LARGE_PARALLEL_IO])
@@ -2781,69 +2780,6 @@ if test -n "$PARALLEL"; then
;;
esac
- ## --------------------------------------------------------------------
- ## Do we want MPE instrumentation feature on?
- ##
- ## This must be done after enable-parallel is checked since it depends
- ## on a mpich compiler.
- ##
- MPE=yes
- AC_ARG_WITH([mpe],
- [AS_HELP_STRING([--with-mpe=DIR],
- [Use MPE instrumentation [default=no]])],,
- [withval=no])
-
- case "X-$withval" in
- X-|X-no|X-none)
- AC_MSG_CHECKING([for MPE])
- AC_MSG_RESULT([suppressed])
- unset MPE
- ;;
- X-yes)
- AC_CHECK_HEADERS([mpe.h],, [unset MPE])
- AC_CHECK_LIB([mpe], [MPE_Init_log],, [unset MPE])
- ;;
- *)
- case "$withval" in
- *,*)
- mpe_inc="`echo $withval | cut -f1 -d,`"
- mpe_lib="`echo $withval | cut -f2 -d, -s`"
- ;;
- *)
- if test -n "$withval"; then
- mpe_inc="$withval/include"
- mpe_lib="$withval/lib"
- fi
- ;;
- esac
-
- if test -n "$mpe_inc"; then
- saved_CPPFLAGS="$CPPFLAGS"
- saved_AM_CPPFLAGS="$AM_CPPFLAGS"
- CPPFLAGS="$CPPFLAGS -I$mpe_inc"
- AM_CPPFLAGS="$AM_CPPFLAGS -I$mpe_inc"
- AC_CHECK_HEADERS([mpe.h],, [CPPFLAGS="$saved_CPPFLAGS"; AM_CPPFLAGS="$saved_AM_CPPFLAGS"; unset MPE])
- else
- AC_CHECK_HEADERS([mpe.h],, [unset MPE])
- fi
-
- if test -n "$mpe_lib"; then
- saved_LDFLAGS="$LDFLAGS"
- saved_AM_LDFLAGS="$AM_LDFLAGS"
- LDFLAGS="$LDFLAGS -L$mpe_lib"
- AM_LDFLAGS="$AM_LDFLAGS -L$mpe_lib"
- AC_CHECK_LIB([mpe], [MPE_Init_log],,
- [LDFLAGS="$saved_LDFLAGS"; AM_LDFLAGS="$saved_AM_LDFLAGS"; unset MPE])
- else
- AC_CHECK_LIB([mpe], [MPE_Init_log],, [unset MPE])
- fi
- ;;
- esac
-
- if test "X-$MPE" = "X-yes"; then
- AC_DEFINE([HAVE_MPE], [1], [Define if we have MPE support])
- fi
-
## ----------------------------------------------------------------------
## Check for the MPI functions necessary for the Parallel Compression
## feature. If these are not present, issue a warning that Parallel