summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2015-03-03 22:27:21 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2015-03-03 22:27:21 (GMT)
commitf56cb6a8f0e5f5314f3c439efc566e7815b88f9c (patch)
tree140ad4c3d2c00f0f6c103497291bb3110e6986d0 /configure.ac
parent6c7aa17753f16b6b7a0a43c724d4a659bf070a91 (diff)
downloadhdf5-f56cb6a8f0e5f5314f3c439efc566e7815b88f9c.zip
hdf5-f56cb6a8f0e5f5314f3c439efc566e7815b88f9c.tar.gz
hdf5-f56cb6a8f0e5f5314f3c439efc566e7815b88f9c.tar.bz2
[svn-r26347] Moves large file and POSIX/GNU defines from AM_CPPFLAGS to H5_CPPFLAGS,
which is where the rest of the #defines reside. The key difference is that AM_CPPFLAGS is exported to h5cc. These #defines are not necessary to consume the HDF5 API and it's bad form to inflict our build configuration on users. In particular, the GNU/POSIX defines could easily conflict with a user's. Fixes: HDFFV-9152 Tested on: h5committest
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b93ba86..e75bd27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1095,7 +1095,7 @@ case "$host_cpu-$host_vendor-$host_os" in
*linux*)
## Make available various LFS-related routines using the following
## _LARGEFILE*_SOURCE macros.
- AM_CPPFLAGS="-D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE $AM_CPPFLAGS"
+ H5_CPPFLAGS="-D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE $H5_CPPFLAGS"
## Add POSIX support on Linux systems, so <features.h> defines
## __USE_POSIX, which is required to get the prototype for fdopen
@@ -1121,7 +1121,7 @@ case "$host_cpu-$host_vendor-$host_os" in
## Need to add this so that O_DIRECT is visible for the direct
## VFD on Linux systems.
- AM_CPPFLAGS="-D_GNU_SOURCE $AM_CPPFLAGS"
+ H5_CPPFLAGS="-D_GNU_SOURCE $H5_CPPFLAGS"
## Also add BSD support on Linux systems, so <features.h> defines
## __USE_BSD, which is required to get the prototype for strdup
@@ -1131,7 +1131,7 @@ case "$host_cpu-$host_vendor-$host_os" in
## http://www.gnu.org/s/libc/manual/html_node/Feature-Test-Macros.html
## however, we do not do this since it breaks the big test on some
## older platforms.
- AM_CPPFLAGS="-D_BSD_SOURCE $AM_CPPFLAGS"
+ H5_CPPFLAGS="-D_BSD_SOURCE $H5_CPPFLAGS"
;;
esac