summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2020-07-10 18:39:59 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2020-07-10 18:39:59 (GMT)
commit0f3fd8d53d9af7e024668c1cfae0780cb9f424dd (patch)
tree9d95358445adc88129bb37216e507cd6bd091eff /configure.ac
parentda607fe4638c9cc08f717fbe65e799c1676c17ff (diff)
downloadhdf5-0f3fd8d53d9af7e024668c1cfae0780cb9f424dd.zip
hdf5-0f3fd8d53d9af7e024668c1cfae0780cb9f424dd.tar.gz
hdf5-0f3fd8d53d9af7e024668c1cfae0780cb9f424dd.tar.bz2
Remove path to szip header file from AM_CPPFLAGS when configure check of libsz fails.
Fix for HDFFV-10830.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d7e3cb5..fb50f94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1604,7 +1604,10 @@ case "X-$withval" in
if test "x$HAVE_SZLIB" = "xyes" -a "x$HAVE_SZLIB_H" = "xyes"; then
AC_CHECK_LIB([sz], [SZ_BufftoBuffCompress],,
- [LDFLAGS="$saved_LDFLAGS"; AM_LDFLAGS="$saved_AM_LDFLAGS"; unset HAVE_SZLIB])
+ [CPPFLAGS="$saved_CPPFLAGS"; AM_CPPFLAGS="$saved_AM_CPPFLAGS"; LDFLAGS="$saved_LDFLAGS"; AM_LDFLAGS="$saved_AM_LDFLAGS"; unset HAVE_SZLIB])
+ if test -z "$HAVE_SZLIB"; then
+ AC_MSG_RESULT([Using SZ_BufftoBuffCompress from libsz in $szlib_lib failed. Szip not enabled.])
+ fi
fi
if test -z "$HAVE_SZLIB" -a -n "$HDF5_CONFIG_ABORT"; then