summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2016-01-28 20:44:11 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2016-01-28 20:44:11 (GMT)
commit6dc56e664bfd9d71951842cf006b7a76eb35cc34 (patch)
tree2f8567c24480946058ab87c9927a01256988b038 /configure.ac
parenta969fbf6040707b4d4b099a7b2c19be787908230 (diff)
downloadhdf5-6dc56e664bfd9d71951842cf006b7a76eb35cc34.zip
hdf5-6dc56e664bfd9d71951842cf006b7a76eb35cc34.tar.gz
hdf5-6dc56e664bfd9d71951842cf006b7a76eb35cc34.tar.bz2
[svn-r29011] LFS changes in the autotools and library.
* We assume that fseeko and ftello exist. * The *64 IO functions and types are no longer explicitly used. We now rely on a mapping provided by _FILE_OFFSET_BITS (or its equivalent). * _LARGEFILE(64)_SOURCE is no longer exposed via AM_CPPFLAGS. The CMake files have not yet been updated but CMake is still functional. The CMake configure files will just run a few unecessary tests and create unneeded #defines until they are updated in a few days. Tested on: Linux, OS X, Solaris, z/OS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 0 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 2f81607..4ab4245 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1045,10 +1045,6 @@ fi
##
case "$host_cpu-$host_vendor-$host_os" in
*linux*)
- ## Make available various LFS-related routines using the following
- ## _LARGEFILE*_SOURCE macros.
- AM_CPPFLAGS="-D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE $AM_CPPFLAGS"
-
## Add POSIX support on Linux systems, so <features.h> defines
## __USE_POSIX, which is required to get the prototype for fdopen
## defined correctly in <stdio.h>.
@@ -1083,23 +1079,6 @@ esac
CPPFLAGS="$H5_CPPFLAGS $AM_CPPFLAGS $CPPFLAGS"
CFLAGS="$H5_CFLAGS $AM_CFLAGS $CFLAGS"
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#include <sys/types.h>
-]],
- [[off64_t n = 0;]])],
- [AC_CHECK_FUNCS([lseek64 fseeko64 ftello64 ftruncate64])],
- [AC_MSG_RESULT([skipping test for lseek64, fseeko64 , ftello64, ftruncate64 because off64_t is not defined])])
-
-AC_CHECK_FUNCS([fseeko ftello])
-
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#include <sys/types.h>
-#include <sys/stat.h>
-]],
-[[struct stat64 sb;]])],
-[AC_CHECK_FUNCS([stat64 fstat64])],
-[AC_MSG_RESULT([skipping test for stat64 and fstat64])])
-
## Checkpoint the cache
AC_CACHE_SAVE
@@ -1150,7 +1129,6 @@ cat >>confdefs.h <<\EOF
#include <sys/types.h> /*for off_t definition*/
EOF
AC_CHECK_SIZEOF([off_t])
-AC_CHECK_SIZEOF([off64_t])
if test "X$C9x" = "Xyes"; then
cat >>confdefs.h <<\EOF