summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2016-02-17 02:16:27 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2016-02-17 02:16:27 (GMT)
commit77f2f1c132a852eb8e0893f051b128cf8f42a9ef (patch)
tree1261652837e5e9895096135b365535603ed95ce5 /configure.ac
parentad0925c214c9d3afe9a013aa1e3adfb2bc3ba4dc (diff)
downloadhdf5-77f2f1c132a852eb8e0893f051b128cf8f42a9ef.zip
hdf5-77f2f1c132a852eb8e0893f051b128cf8f42a9ef.tar.gz
hdf5-77f2f1c132a852eb8e0893f051b128cf8f42a9ef.tar.bz2
[svn-r29131] Updated the GNU g++ compiler config file to use the new debug/
production, etc. system. Tested on: 64-bit Ubuntu 15.10 (Linux 4.2.0 x86_64) gcc 5.2.1 autotools serial - prod/debug w/ C++
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ed6c3b5..8f84a72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2056,21 +2056,25 @@ AC_SUBST([OPTIMIZATION])
case "X-$OPTIMIZATION" in
X-high)
H5_CFLAGS="$H5_CFLAGS $HIGH_OPT_CFLAGS"
+ H5_CXXFLAGS="$H5_CXXFLAGS $HIGH_OPT_CXXFLAGS"
H5_FCFLAGS="$H5_FCFLAGS $HIGH_OPT_FCFLAGS"
AC_MSG_RESULT([high])
;;
X-debug)
H5_CFLAGS="$H5_CFLAGS $DEBUG_OPT_CFLAGS"
+ H5_CXXFLAGS="$H5_CXXFLAGS $DEBUG_OPT_CXXFLAGS"
H5_FCFLAGS="$H5_FCFLAGS $DEBUG_OPT_FCFLAGS"
AC_MSG_RESULT([debug])
;;
X-none)
H5_CFLAGS="$H5_CFLAGS $NO_OPT_CFLAGS"
+ H5_CXXFLAGS="$H5_CXXFLAGS $NO_OPT_CXXFLAGS"
H5_FCFLAGS="$H5_FCFLAGS $NO_OPT_FCFLAGS"
AC_MSG_RESULT([none])
;;
*)
H5_CFLAGS="$H5_CFLAGS $OPTIMIZATION"
+ H5_CXXFLAGS="$H5_CXXFLAGS $OPTIMIZATION"
H5_FCFLAGS="$H5_FCFLAGS $OPTIMIZATION"
OPTIMIZATION="custom ($OPTIMIZATION)"
AC_MSG_RESULT([$OPTIMIZATION])