summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2021-06-23 03:29:52 (GMT)
committerGitHub <noreply@github.com>2021-06-23 03:29:52 (GMT)
commit82c8013a2db4d9a105b5079542526c0bb6c001bf (patch)
treeb0aef2a933c952a4d0b0f5d3464448d3a764b990 /configure.ac
parente25fa1c619017814718a4ae7cae92fb418aa5445 (diff)
downloadhdf5-82c8013a2db4d9a105b5079542526c0bb6c001bf.zip
hdf5-82c8013a2db4d9a105b5079542526c0bb6c001bf.tar.gz
hdf5-82c8013a2db4d9a105b5079542526c0bb6c001bf.tar.bz2
Removes outdated checks for ways inline might be defined (#781)
These are obsolete now that we require C99.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 0 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index cb8f97a..f9b823a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2037,27 +2037,6 @@ AC_CHECK_FUNCS([tmpfile asprintf vasprintf waitpid])
##
AC_C_CONST
-AC_MSG_CHECKING([if the compiler understands __inline__])
-AC_COMPILE_IFELSE(
- [AC_LANG_SOURCE([[static __inline__ void f(void){return;};]])],
- [AC_DEFINE([HAVE___INLINE__], [1], [Define if the compiler understands __inline__]) AC_MSG_RESULT([yes])],
- [AC_MSG_RESULT([no])]
-)
-
-AC_MSG_CHECKING([if the compiler understands __inline])
-AC_COMPILE_IFELSE(
- [AC_LANG_SOURCE([[static __inline void f(void){return;};]])],
- [AC_DEFINE([HAVE___INLINE], [1], [Define if the compiler understands __inline]) AC_MSG_RESULT([yes])],
- [AC_MSG_RESULT([no])]
-)
-
-AC_MSG_CHECKING([if the compiler understands inline])
-AC_COMPILE_IFELSE(
- [AC_LANG_SOURCE([[static inline void f(void){return;};]])],
- [AC_DEFINE([HAVE_INLINE], [1], [Define if the compiler understands inline]) AC_MSG_RESULT([yes])],
- [AC_MSG_RESULT([no])]
-)
-
AC_MSG_CHECKING([for __attribute__ extension])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]],[[int __attribute__((unused)) x]])],
[AC_DEFINE([HAVE_ATTRIBUTE], [1],