summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2016-01-26 21:26:12 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2016-01-26 21:26:12 (GMT)
commit8bbdc947c4f92fc9b1711adc0b00337dae2ed666 (patch)
tree4f5f3edadeece803b46ed1c3a84f11a7d266e9ec /configure.ac
parent8aa7c27fb717f481d924ea5f7793b10f35c29947 (diff)
downloadhdf5-8bbdc947c4f92fc9b1711adc0b00337dae2ed666.zip
hdf5-8bbdc947c4f92fc9b1711adc0b00337dae2ed666.tar.gz
hdf5-8bbdc947c4f92fc9b1711adc0b00337dae2ed666.tar.bz2
[svn-r28972] Removed option to clear file buffers from autotools, CMake, and library.
Buffers that will be written to disk will now always be cleared since not doing this has huge security implications. Tested on: 64-bit Ubuntu 15.10 (Linux 4.2.0, x86_64) gcc 5.2.1 serial autotools parallel autotools (MPICH 3.1.4) serial CMake
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 0 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac
index b1c26a2..aeb4cf7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2004,32 +2004,6 @@ case "X-$INSTRUMENT" in
esac
## ----------------------------------------------------------------------
-## Check if they would like to securely clear file buffers before they are
-## written.
-##
-AC_SUBST([CLEARFILEBUF])
-AC_MSG_CHECKING([whether to clear file buffers])
-AC_ARG_ENABLE([clear-file-buffers],
- [AS_HELP_STRING([--enable-clear-file-buffers],
- [Securely clear file buffers before writing
- to file. Default=yes.])],
- [CLEARFILEBUF=$enableval])
-
-case "X-$CLEARFILEBUF" in
- *)
- CLEARFILEBUF=yes
- AC_MSG_RESULT([yes])
- AC_DEFINE([CLEAR_MEMORY], [1],
- [Define if the memory buffers being written to disk should be
- cleared before writing.])
- ;;
- X-no)
- CLEARFILEBUF=no
- AC_MSG_RESULT([no])
- ;;
-esac
-
-## ----------------------------------------------------------------------
## Check if they would like to use a memory checking tool (like valgrind's
## 'memcheck' tool, or Rational Purify, etc) and the library should be
## more scrupulous with it's memory operations. Enabling this also