summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2021-06-01 13:49:39 (GMT)
committerGitHub <noreply@github.com>2021-06-01 13:49:39 (GMT)
commit50d0888f491821435f6884c0c4c516f69ff67927 (patch)
treecfb3c7737ad9850667771206bc6f457da4e489fb /configure.ac
parent4ef33ef7cd0f2af55b34682b6949a101a68436bb (diff)
downloadhdf5-50d0888f491821435f6884c0c4c516f69ff67927.zip
hdf5-50d0888f491821435f6884c0c4c516f69ff67927.tar.gz
hdf5-50d0888f491821435f6884c0c4c516f69ff67927.tar.bz2
C++ warning and build fixes (#707)
* Committing clang-format changes * C++ build and warning updates * Fixes all warnings on C++ (with gcc 9.3) * Updates CMake and Autotools C++ builds * Undo warning clobber Co-authored-by: github-actions <41898282+github-actions[bot]@users.noreply.github.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 5fc0558..56bfbcb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -776,20 +776,6 @@ if test "X$HDF_CXX" = "Xyes"; then
## Change to the C++ language
AC_LANG_PUSH(C++)
- ## Checking if C++ needs old style header files in includes
- PAC_PROG_CXX_HEADERS
-
- ## Checking if C++ can handle namespaces
- PAC_PROG_CXX_NAMESPACE
-
- ## if C++ can handle static cast
- PAC_PROG_CXX_STATIC_CAST
-
- ## Checking if C++ has offsetof extension,
- ## note: this test has to be the last of the C++ tests because it sets a definition
- ## which would be used in the other tests, causing them to fail.
- PAC_PROG_CXX_OFFSETOF
-
else
AC_MSG_RESULT([no])
CXX="no"