summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2015-03-25 19:12:00 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2015-03-25 19:12:00 (GMT)
commite89290b777cec040c4b07079f43df5df2885ba11 (patch)
treee845b9b09ab86f90f364eff3825a69a252f6549a /configure.ac
parent299deb64fb087c2b74649645769f8a873627fa31 (diff)
downloadhdf5-e89290b777cec040c4b07079f43df5df2885ba11.zip
hdf5-e89290b777cec040c4b07079f43df5df2885ba11.tar.gz
hdf5-e89290b777cec040c4b07079f43df5df2885ba11.tar.bz2
[svn-r26584] Description:
Bring r26485 from the autotools_rework branch to the trunk: Remove the ULONG_TO_FLOAT_ACCURATE macro/define, we no longer support the Sandia system where it was necessary. Tested on: Linux/32 2.6.18 (jam) w/serial & parallel (daily tested for >1 week)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac49
1 files changed, 0 insertions, 49 deletions
diff --git a/configure.ac b/configure.ac
index 04122e8..76bfc95 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2574,55 +2574,6 @@ case "`uname`" in
;;
esac
-## ----------------------------------------------------------------------
-## Set the flag to indicate that the machine can accurately convert
-## 'unsigned long' to 'float' values.
-## (This flag should be set for all machines, except for Pathscale compiler
-## on Sandia's Linux machine where the compiler interprets 'unsigned long'
-## values as negative when the first bit of 'unsigned long' is on during
-## the conversion to float.)
-##
-AC_MSG_CHECKING([if accurately converting unsigned long to float values])
-
-AC_CACHE_VAL([hdf5_cv_ulong_to_float_accurate],
- [AC_TRY_RUN([
- int main(void)
- {
- int ret = 0;
- unsigned long l1;
- unsigned long l2;
- unsigned long l3;
- float f1;
- float f2;
- float f3;
-
-
- if(sizeof(unsigned long)==8) {
- l1 = 0xffffffffffffffffUL;
- l2 = 0xffffffffffff0000UL;
- l3 = 0xf000000000000000UL;
-
- f1 = (float)l1;
- f2 = (float)l2;
- f3 = (float)l3;
-
- if((f1 < 0) || (f2 < 0) || (f3 < 0))
- ret = 1;
- }
-
-done:
- exit(ret);
- }
- ], [hdf5_cv_ulong_to_float_accurate=yes], [hdf5_cv_ulong_to_float_accurate=no],)])
-
-if test ${hdf5_cv_ulong_to_float_accurate} = "yes"; then
- AC_DEFINE([ULONG_TO_FLOAT_ACCURATE], [1],
- [Define if your system accurately converting unsigned long to float values.])
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-
## ----------------------------------------------------------------------
## Set the flag to indicate that the machine can accurately convert