summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2021-05-28 15:48:51 (GMT)
committerGitHub <noreply@github.com>2021-05-28 15:48:51 (GMT)
commitf86004dbde46d4aff365cc7d0a5c503ff60d3416 (patch)
tree44f69fe2bdba7e91ef1aec46f8c19e8adaee6389 /configure.ac
parent2ddf5fbd92ebdb0d59e208d88f159eec8a1ffbf8 (diff)
downloadhdf5-f86004dbde46d4aff365cc7d0a5c503ff60d3416.zip
hdf5-f86004dbde46d4aff365cc7d0a5c503ff60d3416.tar.gz
hdf5-f86004dbde46d4aff365cc7d0a5c503ff60d3416.tar.bz2
Normalization with develop (#704)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 1 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index d6dc7b3..09da906 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1251,8 +1251,6 @@ AC_CHECK_HEADERS([sys/resource.h sys/time.h unistd.h sys/ioctl.h sys/stat.h])
AC_CHECK_HEADERS([sys/socket.h sys/types.h sys/file.h])
AC_CHECK_HEADERS([stddef.h setjmp.h features.h])
AC_CHECK_HEADERS([dirent.h])
-AC_CHECK_HEADERS([stdint.h], [C9x=yes])
-AC_CHECK_HEADERS([stdbool.h])
AC_CHECK_HEADERS([netdb.h netinet/in.h arpa/inet.h])
## Darwin
@@ -1417,11 +1415,7 @@ AC_CHECK_SIZEOF([off_t])
if test "X$C9x" = "Xyes"; then
cat >>confdefs.h <<\EOF
-#ifdef HAVE_STDBOOL_H
-#include <stdbool.h> /* for bool definition */
-#else
-#define bool _Bool
-#endif
+#include <stdbool.h>
EOF
AC_CHECK_SIZEOF([bool])
fi
@@ -1932,10 +1926,8 @@ if test "x$HAVE_PTHREAD" = "xyes"; then
AC_CACHE_VAL([hdf5_cv_system_scope_threads],
[AC_RUN_IFELSE(
[AC_LANG_PROGRAM([
- #if STDC_HEADERS
#include <stdlib.h>
#include <pthread.h>
- #endif
],[
pthread_attr_t attribute;
int ret;