summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Young <dyoung@hdfgroup.org>2019-10-03 20:56:34 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2020-05-20 14:17:25 (GMT)
commit8d3d45789064a1931f538b5d54c70316edfa4b4a (patch)
tree9a6c0726500750f5a7917784a05d114cdceccc4b /configure.ac
parent4c481e55648422e3777f34ef5f657a7f976b4e43 (diff)
downloadhdf5-8d3d45789064a1931f538b5d54c70316edfa4b4a.zip
hdf5-8d3d45789064a1931f538b5d54c70316edfa4b4a.tar.gz
hdf5-8d3d45789064a1931f538b5d54c70316edfa4b4a.tar.bz2
Let us override the examples directory using --with-examplesdir=DIR.
This is handy for NetBSD where HDF5 examples are installed by convention in $prefix/share/examples/hdf5/ rather than in ${prefix}/share/hdf5_examples/, which is the HDF5 default. Place hdf5_examples/ under ${datarootdir} which on most systems will be ${prefix}/share/, anyway.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 34a678a..2819c5d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2992,6 +2992,28 @@ fi
AC_CACHE_SAVE
## ----------------------------------------------------------------------
+## Use custom examples path.
+##
+AC_MSG_CHECKING([for custom examples path definition])
+AC_ARG_WITH([examplesdir],
+ [AS_HELP_STRING([--with-examplesdir=location],
+ [Specify path for examples
+ [default="DATAROOTDIR/hdf5_examples"]])],,
+ withval="${datarootdir}/hdf5_examples")
+
+if test "X$withval" = "X"; then
+ AC_MSG_RESULT([default])
+ examplesdir="${datarootdir}/hdf5_examples"
+else
+ AC_MSG_RESULT([$withval])
+ examplesdir=$withval
+fi
+
+AC_SUBST([examplesdir])
+AC_DEFINE_UNQUOTED([EXAMPLESDIR], ["$examplesdir"],
+ [Define the examples directory])
+
+## ----------------------------------------------------------------------
## Enable custom plugin default path for library. It requires SHARED support.
##
AC_MSG_CHECKING([for custom plugin default path definition])