summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2022-04-21 05:24:35 (GMT)
committerGitHub <noreply@github.com>2022-04-21 05:24:35 (GMT)
commitec14985c8555bda02021568ea20295384a2cef7e (patch)
tree491c1f08a68d92e400d939d96fefdc7bfef57ddc /configure.ac
parentbc62da7eb911727497475d1cc90991230f33fa3d (diff)
downloadhdf5-ec14985c8555bda02021568ea20295384a2cef7e.zip
hdf5-ec14985c8555bda02021568ea20295384a2cef7e.tar.gz
hdf5-ec14985c8555bda02021568ea20295384a2cef7e.tar.bz2
VFD SWMR: Merges from develop (#1670)
* Cleans up SWMR test scripts (both legacy and VFD) * Brings over format source changes for Java * Normalization of HL, Fortran, C++, Java w/ develop * Removes the STATIC flavor of FUNC_ENTER macros (#1622) * Removes the STATIC flavor of FUNC_ENTER macros * Remove H5_NO_ALIGNMENT_RESTRICTIONS (#1426) * Do not conditionally compile code that uses a pointer dereference and assignment to copy a potentially unaligned variable to aligned automatic storage, or vice versa. Instead, always use naked `memcpy(3)`s. Disassembling the generated code reveals that the `memcpy(3)`s optimize (`-O3`) to a single `mov` instruction for x86_64, which is not strict about alignment. This change reduces the size of code and scripts by 143 lines, eases our way to cross-compilation, and avoids invoking undefined behavior. * Committing clang-format changes * Per discussion, use HD and add comments. Co-authored-by: github-actions <41898282+github-actions[bot]@users.noreply.github.com> * Removes unused definitions from module headers (#1624) * Misc stuff from develop (includes some parallel things) * Brings over SWMR test quiet mode changes from develop Co-authored-by: github-actions <41898282+github-actions[bot]@users.noreply.github.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 0 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 66fc225..3a1aa69 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4039,25 +4039,6 @@ AC_ARG_ENABLE([embedded-libinfo],
## ----------------------------------------------------------------------
-## Check if pointer alignments are enforced
-##
-AC_MSG_CHECKING([if alignment restrictions are strictly enforced])
-
-TEST_SRC="`(echo \"#define H5_NO_ALIGNMENT_RESTRICTIONS_TEST 1\"; cat $srcdir/config/cmake/ConversionTests.c)`"
-
-AC_RUN_IFELSE([
- AC_LANG_SOURCE([$TEST_SRC])
- ], [
- AC_DEFINE([NO_ALIGNMENT_RESTRICTIONS], [1], [Define if we can violate pointer alignment restrictions])
- AC_MSG_RESULT([no])
- ], [
- AC_MSG_RESULT([yes])
- ], [
- AC_MSG_RESULT([unknown, assuming yes])
- ])
-
-
-## ----------------------------------------------------------------------
## Restore user's CFLAGS.
CFLAGS="$saved_user_CFLAGS"
FCFLAGS="$saved_user_FCFLAGS"