summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2022-03-23 13:48:05 (GMT)
committerGitHub <noreply@github.com>2022-03-23 13:48:05 (GMT)
commitfbb532cd633e216f47ce846493b38af02cfbb43a (patch)
tree1ef7bc9f25ec0832f8b25bb8ea4be34d53bd144d /configure.ac
parent78375882485a99a81caa933928ed08d7a38ef88b (diff)
downloadhdf5-fbb532cd633e216f47ce846493b38af02cfbb43a.zip
hdf5-fbb532cd633e216f47ce846493b38af02cfbb43a.tar.gz
hdf5-fbb532cd633e216f47ce846493b38af02cfbb43a.tar.bz2
VFD SWMR: Normalization with develop (#1506)
* Brought over plugin and test script changes * Removes remaining register keywords (#1481) * Fixed warnings in the aux process code * Minor fixes from develop * Minor changes from develop, fixed format warnings * Formatted source * Added HD prefix to timespec_get * Cleanup in new files * Removes the MANIFEST file and unused release files (#1497) * Removes the MANIFEST file and unused release files * Updated tar command * checkposix corrections * More checkposix fixes * Ripped out unused instrumentation functionality * Brought over cache tagging changes from develop * Changes to tagged metadata expulsion iteration * Fixed typo * Brought over H5O__free() changes from develop * Brings (unused) parallel page buffer test in line with develop * Moved the functionality in supervise.subr to test_vfd_swmr.sh * Tools VFD parameter updates * Committing clang-format changes * H5F VFD SWMR refactoring * Committing clang-format changes * Misc changes Co-authored-by: github-actions <41898282+github-actions[bot]@users.noreply.github.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 22 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 53d181b..9b685c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2707,9 +2707,11 @@ AC_ARG_ENABLE([memory-alloc-sanity-check],
[Enable this option to turn on internal memory
allocation sanity checking. This could cause
more memory use and somewhat slower allocation.
- This option is orthogonal to the
- --enable-using-memchecker option.
- [default=yes if debug build, otherwise no]
+ This option may also cause issues with HDF5
+ filter plugins, so should not be enabled if
+ filters are to be used. This option is orthogonal
+ to the --enable-using-memchecker option.
+ [default=no]
])],
[MEMORYALLOCSANITYCHECK=$enableval])
@@ -2719,11 +2721,10 @@ AC_SUBST([MEMORYALLOCSANITYCHECK])
## Set default
if test "X-$MEMORYALLOCSANITYCHECK" = X- ; then
- if test "X-$BUILD_MODE" = "X-debug" ; then
- MEMORYALLOCSANITYCHECK=yes
- else
- MEMORYALLOCSANITYCHECK=no
- fi
+# Should consider enabling this option by default for
+# 'developer' builds if that build mode is added in
+# the future
+ MEMORYALLOCSANITYCHECK=no
fi
case "X-$MEMORYALLOCSANITYCHECK" in
@@ -4213,21 +4214,20 @@ AC_CONFIG_FILES([src/libhdf5.settings
src/Makefile
test/Makefile
test/H5srcdir_str.h
- test/testabort_fail.sh
- test/testcheck_version.sh
- test/testerror.sh
- test/testexternal_env.sh
- test/testflushrefresh.sh
- test/testlibinfo.sh
- test/testlinks_env.sh
- test/testswmr.sh
- test/testvfdswmr.sh
- test/testvds_env.sh
- test/testvdsswmr.sh
- test/test_filter_plugin.sh
+ test/test_abort_fail.sh
+ test/test_check_version.sh
+ test/test_error.sh
+ test/test_external_env.sh
+ test/test_flush_refresh.sh
+ test/test_libinfo.sh
+ test/test_links_env.sh
test/test_mirror.sh
- test/test_usecases.sh
- test/test_vol_plugin.sh
+ test/test_plugin.sh
+ test/test_swmr.sh
+ test/test_use_cases.sh
+ test/test_vds_env.sh
+ test/test_vds_swmr.sh
+ test/test_vfd_swmr.sh
testpar/Makefile
testpar/testpflush.sh
utils/Makefile