summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2021-01-08 12:52:08 (GMT)
committerGitHub <noreply@github.com>2021-01-08 12:52:08 (GMT)
commit9e1739f76f42d5849a069a8ac86125a5f1d23edb (patch)
treef47cd81cc4750b89f444e1a704d78e327a10f0bb /configure.ac
parente3b7d68826b5ce54518220d80dfb723f04c7b486 (diff)
downloadhdf5-9e1739f76f42d5849a069a8ac86125a5f1d23edb.zip
hdf5-9e1739f76f42d5849a069a8ac86125a5f1d23edb.tar.gz
hdf5-9e1739f76f42d5849a069a8ac86125a5f1d23edb.tar.bz2
Fixes Autotools detection of the st_blocks field in stat (#246)
* Fixes Autotools detection of the st_blocks field in stat The Autotools and CMake will now both correctly determine if the stat struct has the st_blocks field and set H5_HAVE_STAT_ST_BLOCKS appropriately. * Fixes a typo in configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ca3a1bb..4677c15 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1986,10 +1986,10 @@ esac
## ----------------------------------------------------------------------
-## Does the struct stat have the st_blocks field? This field is not Posix.
+## Does the struct stat have the st_blocks field? This field is not POSIX.
##
AC_MSG_CHECKING([for st_blocks in struct stat])
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM[[
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <sys/stat.h>]],[[struct stat sb; sb.st_blocks=0;]])],
[AC_DEFINE([HAVE_STAT_ST_BLOCKS], [1],
[Define if struct stat has the st_blocks field])