summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2016-07-20 16:10:42 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2016-07-20 16:10:42 (GMT)
commit3f37d67b3ca8f6693400a2d266753aaae63ded93 (patch)
tree10145aca0a4af7372b92bd7b7d0bd43202c395e1 /configure.ac
parent33e8407350dbc412e60cd4b2f5d7bdf681f001cb (diff)
downloadhdf5-3f37d67b3ca8f6693400a2d266753aaae63ded93.zip
hdf5-3f37d67b3ca8f6693400a2d266753aaae63ded93.tar.gz
hdf5-3f37d67b3ca8f6693400a2d266753aaae63ded93.tar.bz2
[svn-r30209] HDFFV-9467: Use the same test programs for CMake and autotools
-- Modified C++ to use the same test programs. Tested: jelly (gnu)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5ba01c6..a6d1192 100644
--- a/configure.ac
+++ b/configure.ac
@@ -695,12 +695,14 @@ if test "X$HDF_CXX" = "Xyes"; then
## Checking if C++ can handle namespaces
PAC_PROG_CXX_NAMESPACE
- ## Checking if C++ has offsetof extension
- PAC_PROG_CXX_OFFSETOF
-
## if C++ can handle static cast
PAC_PROG_CXX_STATIC_CAST
+ ## Checking if C++ has offsetof extension,
+ ## note: this test has to be the last of the C++ tests because it sets a definition
+ ## which would be used in the other tests, causing them to fail.
+ PAC_PROG_CXX_OFFSETOF
+
else
AC_MSG_RESULT([no])
CXX="no"