summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorjhendersonHDF <jhenderson@hdfgroup.org>2022-03-03 15:46:18 (GMT)
committerGitHub <noreply@github.com>2022-03-03 15:46:18 (GMT)
commitba032bb28bfff3b8d330b026cbd01e6e44be7578 (patch)
treea255ce185695186bfd965137151c63e05cd81a92 /configure.ac
parent7c18723404757cf96175df68c402cbc77ad0665e (diff)
downloadhdf5-ba032bb28bfff3b8d330b026cbd01e6e44be7578.zip
hdf5-ba032bb28bfff3b8d330b026cbd01e6e44be7578.tar.gz
hdf5-ba032bb28bfff3b8d330b026cbd01e6e44be7578.tar.bz2
Disable memory alloc sanity checks by default for Autotools debug builds (#1468)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 9 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 0ad2228..e426632 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2710,9 +2710,11 @@ AC_ARG_ENABLE([memory-alloc-sanity-check],
[Enable this option to turn on internal memory
allocation sanity checking. This could cause
more memory use and somewhat slower allocation.
- This option is orthogonal to the
- --enable-using-memchecker option.
- [default=yes if debug build, otherwise no]
+ This option may also cause issues with HDF5
+ filter plugins, so should not be enabled if
+ filters are to be used. This option is orthogonal
+ to the --enable-using-memchecker option.
+ [default=no]
])],
[MEMORYALLOCSANITYCHECK=$enableval])
@@ -2722,11 +2724,10 @@ AC_SUBST([MEMORYALLOCSANITYCHECK])
## Set default
if test "X-$MEMORYALLOCSANITYCHECK" = X- ; then
- if test "X-$BUILD_MODE" = "X-debug" ; then
- MEMORYALLOCSANITYCHECK=yes
- else
- MEMORYALLOCSANITYCHECK=no
- fi
+# Should consider enabling this option by default for
+# 'developer' builds if that build mode is added in
+# the future
+ MEMORYALLOCSANITYCHECK=no
fi
case "X-$MEMORYALLOCSANITYCHECK" in