summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2015-09-11 03:38:22 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2015-09-11 03:38:22 (GMT)
commit6bd0add89a6ae02e66b6b1cae68d58b6798a825a (patch)
tree9fd6485f81117cd06241bd5552c72fa433e59707 /configure.ac
parentf402195f59fb928d45b846435076c9fe96e5fcbb (diff)
downloadhdf5-6bd0add89a6ae02e66b6b1cae68d58b6798a825a.zip
hdf5-6bd0add89a6ae02e66b6b1cae68d58b6798a825a.tar.gz
hdf5-6bd0add89a6ae02e66b6b1cae68d58b6798a825a.tar.bz2
[svn-r27756] Merge of r27692 from trunk
Changed the autotools files so that the high-level library is unsupported when building the thread-safe library. Configure will quit with an error when --disable-hl or --enable-unsupported is not used with --enable-threadsafe. Fixes HDFFV-8719 Tested on: h5committest configure w/ various combinations of --enable-threadsafe, --disable-hl, and --enable-unsupported
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index af391da..e058a49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1377,9 +1377,21 @@ AC_CACHE_SAVE
AC_MSG_CHECKING([for thread safe support])
AC_ARG_ENABLE([threadsafe],
[AS_HELP_STRING([--enable-threadsafe],
- [Enable thread-safe capability])],
+ [Enable thread-safe capability. Not compatible with the high-level library, Fortran, or C++ wrappers.
+ [default=no]])],
[THREADSAFE=$enableval])
+## --enable-threadsafe is incompatible with --enable-hl unless
+## --enable-unsupported has been specified on the configure line.
+##
+## Note that the high-level library is enabled by default so most
+## users will have to add --disable-hl to the configure options.
+if test "X${ALLOW_UNSUPPORTED}" != "Xyes"; then
+ if test "X${HDF5_HL}" = "Xyes" -a "X${enable_threadsafe}" = "Xyes"; then
+ AC_MSG_ERROR([The thread-safe library is incompatible with the high-level library. --disable-hl can be used to prevent building the high-level library (recommended). Alternatively, --enable-unsupported will allow building the high-level library, though this configuration is not supported by The HDF Group.])
+ fi
+fi
+
## The --enable-threadsafe flag is not compatible with --enable-cxx.
## If the user tried to specify both flags, throw an error, unless
## they also provided the --enable-unsupported flag.