summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2015-06-10 21:37:42 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2015-06-10 21:37:42 (GMT)
commit849555ef99170b02151eb72cf14d0ce7e0cc5a22 (patch)
tree076a488c3a4e26be73536227947baf053cdf1c74 /configure.ac
parent5ec5c1dd65c55d4e00545c41a39feaae072e323f (diff)
downloadhdf5-849555ef99170b02151eb72cf14d0ce7e0cc5a22.zip
hdf5-849555ef99170b02151eb72cf14d0ce7e0cc5a22.tar.gz
hdf5-849555ef99170b02151eb72cf14d0ce7e0cc5a22.tar.bz2
[svn-r27189] Merge change from hdf5_1_8_15 to hdf5_1_8.
Chane addressed HDFFV-9010: configure issue with gcc 4.9.2; libtool produced "-l " with no lib name. Also Scot noted that the -i option for sed does not work on Solaris or Mac, so the sed output is written to a temp file and then moved to the libtool file Tested h5committest.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ccf5dc5..e1fee46 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3116,5 +3116,14 @@ cat >> src/H5config.h <<EOF
#endif
EOF
+## HDF5 configure code created by autotools with gcc 4.9.2 is adding problematic
+## linker flags: -l with no library name; -l <libname>, specifically gfortran or m.
+## This sed script corrects "-l <libname>" first and then "-l " with no library name.
+## If the order is not preserved, all instances of "-l " will be removed.
+## The -i option for sed doesn't work on some systems, so a temporary file is used
+## and used to overwrite the original libtool file.
+sed -e '/^postdeps/ s/-l \([a-zA-Z]\)/-l\1/g' -e '/^postdeps/ s/-l //g' libtool > libtool_rev
+mv -f libtool_rev libtool
+
## show the configure settings
cat src/libhdf5.settings