summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2014-07-18 22:17:58 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2014-07-18 22:17:58 (GMT)
commit442f9854645775a2bc7b20efe2170fb5a15ea29b (patch)
treebe5df249ef8c9d178797bc1be422f251192de8cf /configure.ac
parentb79ca69a25aa612a97bc0aaa13710a2bf27a6376 (diff)
downloadhdf5-442f9854645775a2bc7b20efe2170fb5a15ea29b.zip
hdf5-442f9854645775a2bc7b20efe2170fb5a15ea29b.tar.gz
hdf5-442f9854645775a2bc7b20efe2170fb5a15ea29b.tar.bz2
[svn-r25433] Brought changes from the trunk into the branch.
For the top level, brings in changes for configure.ac, configure and the MANIFEST: svn merge -c25286 https://svn.hdfgroup.uiuc.edu/hdf5/trunk . svn merge -c25287 https://svn.hdfgroup.uiuc.edu/hdf5/trunk . svn merge -c25290 https://svn.hdfgroup.uiuc.edu/hdf5/trunk . For the fortran level: 384 17:00 svn merge -r25235:25272 https://svn.hdfgroup.uiuc.edu/hdf5/trunk/fortran 389 17:01 svn merge -r25284:25432 https://svn.hdfgroup.uiuc.edu/hdf5/trunk/fortran For the fortran merges, I skipped changes relating to hyperslab selection since the C source has not been merged from the trunk yet. These changes should be in place in the fortran source when the C source is merged to the 1.8 branch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6fc6a3c..f230546 100644
--- a/configure.ac
+++ b/configure.ac
@@ -403,6 +403,8 @@ else
fi
HAVE_SIZEOF="no"
+HAVE_C_SIZEOF="no"
+HAVE_STORAGE_SIZE="no"
FORTRAN_DEFAULT_REALisDBLE="no"
if test "X$HDF_FORTRAN" = "Xyes"; then
@@ -483,6 +485,33 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
HAVE_SIZEOF="yes"],
[AC_MSG_RESULT([no])])
+ ## See if the fortran compiler supports the intrinsic function "C_SIZEOF"
+
+ AC_MSG_CHECKING([if Fortran compiler supports intrinsic C_SIZEOF])
+ AC_TRY_RUN([
+ PROGRAM main
+ USE ISO_C_BINDING
+ INTEGER(C_INT) :: a
+ INTEGER(C_SIZE_T) :: result
+ result = C_SIZEOF(a)
+ END PROGRAM
+ ], [AC_MSG_RESULT([yes])
+ HAVE_C_SIZEOF="yes"],
+ [AC_MSG_RESULT([no])])
+
+ ## See if the fortran compiler supports the intrinsic function "STORAGE_SIZE"
+
+ AC_MSG_CHECKING([if Fortran compiler supports intrinsic STORAGE_SIZE])
+ AC_TRY_RUN([
+ PROGRAM main
+ INTEGER :: a
+ INTEGER :: result
+ result = STORAGE_SIZE(a)
+ END PROGRAM
+ ], [AC_MSG_RESULT([yes])
+ HAVE_STORAGE_SIZE="yes"],
+ [AC_MSG_RESULT([no])])
+
## Check to see if -r8 was specified to determine if we need to
## compile the DOUBLE PRECISION interfaces.
@@ -552,6 +581,8 @@ fi
AC_LANG_POP(Fortran)
AM_CONDITIONAL([FORTRAN_HAVE_SIZEOF], [test "X$HAVE_SIZEOF" = "Xyes"])
+AM_CONDITIONAL([FORTRAN_HAVE_C_SIZEOF], [test "X$HAVE_C_SIZEOF" = "Xyes"])
+AM_CONDITIONAL([FORTRAN_HAVE_STORAGE_SIZE], [test "X$HAVE_STORAGE_SIZE" = "Xyes"])
AM_CONDITIONAL([FORTRAN_2003_CONDITIONAL_F], [test "X$HAVE_FORTRAN_2003" = "Xyes"])
AM_CONDITIONAL([FORTRAN_DEFAULT_REALisDBLE_F], [test "X$FORTRAN_DEFAULT_REALisDBLE" = "Xyes"])