summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRaymond Lu <songyulu@hdfgroup.org>2013-09-30 21:51:26 (GMT)
committerRaymond Lu <songyulu@hdfgroup.org>2013-09-30 21:51:26 (GMT)
commit497507f5a90977efe1241eae0230b830f17ecbec (patch)
tree930d768bc3da01e8ae8429c1e18e4f215a7376e5 /configure.ac
parent03c29f0ffda11bf521c0951bca0a423c4b8258d9 (diff)
downloadhdf5-497507f5a90977efe1241eae0230b830f17ecbec.zip
hdf5-497507f5a90977efe1241eae0230b830f17ecbec.tar.gz
hdf5-497507f5a90977efe1241eae0230b830f17ecbec.tar.bz2
[svn-r24231] Issue 1264: CYGWIN had long double rounding problem from unsigned long long. Allen confirmed the problem is gone. So I took
out the macro CYGWIN_ULLONG_TO_LDOUBLE_ROUND_PROBLEM. It skipped the test related to this issue. Tested with h5committest.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 3b1bd8c..93ed71b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1019,18 +1019,6 @@ if test "X${ALLOW_UNSUPPORTED}" != "Xyes"; then
fi
## ----------------------------------------------------------------------
-## The GCC compiler on Cygwin running on Windows XP has rounding problem
-## in the data conversion dt_arith.c from unsigned long long to long
-## double (see bug HDFFV-1264). I define a macro here to skip the test for
-## Cygwin. I'll come back and figure out the problem once I'm available.
-## 2010/5/5 - SLU
-case "`uname`" in
- CYGWIN*)
- AC_DEFINE([CYGWIN_ULLONG_TO_LDOUBLE_ROUND_PROBLEM], [1], [Define a macro for Cygwin (on XP only) where the compiler has rounding problem converting from unsigned long long to long double])
- ;;
-esac
-
-## ----------------------------------------------------------------------
## Windows won't create DLLs without the following macro.
##
AC_LIBTOOL_WIN32_DLL