summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-08-26 15:35:15 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-08-26 15:35:15 (GMT)
commit8194f34ef79a58dc5e57b374873be4e50ad7ad7b (patch)
tree876b1d75477a2babe7fd8a7ef555611825e52526 /configure.ac
parenta17e786cd732ca3af91ebb473a0bd116f391c94a (diff)
downloadhdf5-8194f34ef79a58dc5e57b374873be4e50ad7ad7b.zip
hdf5-8194f34ef79a58dc5e57b374873be4e50ad7ad7b.tar.gz
hdf5-8194f34ef79a58dc5e57b374873be4e50ad7ad7b.tar.bz2
[svn-r24072] Merge trunk cmake changes to 1.8 branch.
Also add default switch blocks to h5import. Merge h5dump any_path option from trunk. Tested: local linux
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 3 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index f38fd6e..19052c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -433,14 +433,6 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
AC_SUBST([OBJECT_NAMELEN_DEFAULT_F])
## --------------------------------------------------------------------
- ## General Fortran flags
- ## Only add FFLAGS to FCFLAGS if it's set.
- if test "x$FFLAGS" != "x" ; then
- AM_FCFLAGS="${AM_FCFLAGS} ${FFLAGS}"
- FCFLAGS="${FCFLAGS} ${FFLAGS}"
- fi
-
- ## --------------------------------------------------------------------
## Fortran source extention
##
AC_FC_SRCEXT([f90])
@@ -1507,7 +1499,7 @@ case "$host_cpu-$host_vendor-$host_os" in
;;
esac
-## Need to add the AM_ and H5_ into CPFLAGS/CPPFLAGS to make them visible
+## Need to add the AM_ and H5_ into CFLAGS/CPPFLAGS to make them visible
## for configure checks.
## Note: Both will be restored by the end of configure.
CPPFLAGS="$H5_CPPFLAGS $AM_CPPFLAGS $CPPFLAGS"
@@ -2755,10 +2747,7 @@ case "X-$enable_parallel" in
integer:: ierr
call mpi_file_open( ierr )
end],,
- [AC_CHECK_LIB([mpi], [
- include 'mpif.h'
- integer:: ierr
- call mpi_file_open( ierr )],, [PARALLEL=no])])
+ [AC_CHECK_LIB([mpi], [mpi_file_open],, [PARALLEL=no])])
## Then try link a simple MPI-IO program. If fail, try again with
## -lmpio.
@@ -2769,10 +2758,7 @@ case "X-$enable_parallel" in
integer:: ierr
call mpi_file_open( ierr )
end],,
- [AC_CHECK_LIB([mpio], [
- include 'mpif.h'
- integer:: ierr
- call mpi_file_open( ierr )],, [PARALLEL=no])])
+ [AC_CHECK_LIB([mpio], [mpi_file_open],, [PARALLEL=no])])
fi
## Change to the C language