summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2016-02-03 19:16:36 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2016-02-03 19:16:36 (GMT)
commit184800782f1cde808e8f7244938a8456333a39c7 (patch)
tree5df15dfd9cec08e5dd5e81deaef717535661556e /configure.ac
parentf230bf09ca12c5e435ae1368f75e5dcabd4d5c53 (diff)
downloadhdf5-184800782f1cde808e8f7244938a8456333a39c7.zip
hdf5-184800782f1cde808e8f7244938a8456333a39c7.tar.gz
hdf5-184800782f1cde808e8f7244938a8456333a39c7.tar.bz2
[svn-r29038] Minor fix to configure.ac that fixes a broken --enable-clear-file-buffers
option. Fixes HDFFV-9676 Tested on: jam (just a smoke check to ensure that the library builds and passes tests when the feature is disabled)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 65e1ff6..2933a7d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1897,6 +1897,10 @@ AC_ARG_ENABLE([clear-file-buffers],
[CLEARFILEBUF=$enableval])
case "X-$CLEARFILEBUF" in
+ X-no)
+ CLEARFILEBUF=no
+ AC_MSG_RESULT([no])
+ ;;
*)
CLEARFILEBUF=yes
AC_MSG_RESULT([yes])
@@ -1904,10 +1908,6 @@ case "X-$CLEARFILEBUF" in
[Define if the memory buffers being written to disk should be
cleared before writing.])
;;
- X-no)
- CLEARFILEBUF=no
- AC_MSG_RESULT([no])
- ;;
esac
## ----------------------------------------------------------------------