summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2015-03-25 19:56:23 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2015-03-25 19:56:23 (GMT)
commita877ab37b641f4bb3e63322b67805eb128626771 (patch)
treed83e5f81550f78bbafc998b436d7e3f34a3e12cb /configure.ac
parent5966f8ce26f03a57de337d1f4e853c0af1a7828c (diff)
downloadhdf5-a877ab37b641f4bb3e63322b67805eb128626771.zip
hdf5-a877ab37b641f4bb3e63322b67805eb128626771.tar.gz
hdf5-a877ab37b641f4bb3e63322b67805eb128626771.tar.bz2
[svn-r26588] Description:
Bring r26560 from trunk 1.8 branch: Bring r26483 from autotools_rework branch back to trunk: Remove INTEGER_TO_LDOUBLE_ACCURATE macro/define - we no longer support SGI systems. Tested on: Linux/32 2.6.18 (jam) w/serial & parallel (daily tested for 2+ days)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 0 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 090d900..60876f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2557,27 +2557,6 @@ case "`uname`" in
;;
esac
-## -----------------------------------------------------------------------
-## Set flag to indicate that the machine can handle conversion from
-## integers to long double. (This flag should be set "yes" for all
-## machines except all SGIs, where some conversions are incorrect)
-##
-AC_MSG_CHECKING([if accurately converting from integers to long double])
-
-if test ${ac_cv_sizeof_long_double} = 0; then
- hdf5_cv_integer_to_ldouble_accurate=${hdf5_cv_integer_to_ldouble_accurate=no}
-else
- AC_CACHE_VAL([hdf5_cv_integer_to_ldouble_accurate], [hdf5_cv_integer_to_ldouble_accurate=yes])
-fi
-
-if test ${hdf5_cv_integer_to_ldouble_accurate} = "yes"; then
- AC_DEFINE([INTEGER_TO_LDOUBLE_ACCURATE], [1],
- [Define if your system can accurately convert from integers to long double values.])
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-
## ----------------------------------------------------------------------
## Set the flag to indicate that the machine can accurately convert
## 'unsigned long' to 'float' values.