summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2023-03-27 02:47:32 (GMT)
committerGitHub <noreply@github.com>2023-03-27 02:47:32 (GMT)
commit295f9fefbdf7123b305590c09e89e95e33205ce3 (patch)
treeae9496ccaaad10eb218bcb5a4f74c234413305a1 /configure.ac
parent43e4e64d886e9072a6075c6369e84c0e273fa44f (diff)
downloadhdf5-295f9fefbdf7123b305590c09e89e95e33205ce3.zip
hdf5-295f9fefbdf7123b305590c09e89e95e33205ce3.tar.gz
hdf5-295f9fefbdf7123b305590c09e89e95e33205ce3.tar.bz2
Update version to HDF5 1.10.10-3 for initial release branch version. (#2634)
* Update version to HDF5 1.10.10-3 for initial release branch version. Update RELEASE.txt Update configure.ac for release: switch to production mode, disable maintainer mode Set HDF5_GENERATE_HEADERS to OFF in src/CMakeLists.txt Add files generated by autogen.sh for release. * Fix codespell issues for autotools files generated by autogen.sh. Remove generated autom4te.cache files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 4 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 06d0178..546420b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,7 +22,7 @@ AC_PREREQ([2.69])
## NOTE: Do not forget to change the version number here when we do a
## release!!!
##
-AC_INIT([HDF5], [1.10.10-2], [help@hdfgroup.org])
+AC_INIT([HDF5],[1.10.10-3],[help@hdfgroup.org])
AC_CONFIG_SRCDIR([src/H5.c])
AC_CONFIG_HEADERS([src/H5config.h])
@@ -74,7 +74,7 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])]) # use silent rules where a
##
## By default, maintainer mode is enabled in development branches and disabled
## in release branches.
-AM_MAINTAINER_MODE([enable])
+AM_MAINTAINER_MODE([disable])
## ----------------------------------------------------------------------
## Set prefix default (install directory) to a directory in the build area.
@@ -423,14 +423,14 @@ AC_ARG_ENABLE([build-mode],
(i.e.: a 'clean slate' configuration).
All these settings can be overridden by using
specific configure flags.
- [default=debug]
+ [default=production]
])],
[BUILD_MODE=$enableval])
## Set the default
## Depends on branch, set via script at branch creation time
if test "X-$BUILD_MODE" = X- ; then
- BUILD_MODE=debug
+ BUILD_MODE=production
fi
## Allow this variable to be substituted in
@@ -1338,8 +1338,6 @@ AC_CHECK_LIB([dl], [dlopen])
## ----------------------------------------------------------------------
## Check for system header files.
##
-AC_HEADER_STDC
-AC_HEADER_TIME
## Unix
AC_CHECK_HEADERS([dirent.h features.h pwd.h setjmp.h stdbool.h stddef.h unistd.h])