summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2023-03-18 04:25:50 (GMT)
committerGitHub <noreply@github.com>2023-03-18 04:25:50 (GMT)
commit084247f1cd3bf09df5dd49de3de1874768caaf9f (patch)
tree11c8aff1d73d8f1db07d5919ff75335a206e17bb /configure.ac
parent45f13f1de1b6db0fdc34681b4b8046fa46f921ba (diff)
downloadhdf5-084247f1cd3bf09df5dd49de3de1874768caaf9f.zip
hdf5-084247f1cd3bf09df5dd49de3de1874768caaf9f.tar.gz
hdf5-084247f1cd3bf09df5dd49de3de1874768caaf9f.tar.bz2
Removes dmalloc support (#2239) (#2587)
This has not been used to debug the library in a very long time. Most developers use valgrind, -fsanitize=address, or some other memory checker instead of this library. This removes: * dmalloc.h include from H5private.h * --with-dmalloc= Autotools configure option * HDF5_ENABLE_USING_DMALLOC CMake option
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac76
1 files changed, 0 insertions, 76 deletions
diff --git a/configure.ac b/configure.ac
index a74bddc..1093812 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1560,82 +1560,6 @@ AC_ARG_WITH([fnord],
])
## ----------------------------------------------------------------------
-## Is dmalloc (debug malloc library) requested? It has a header file
-## `dmalloc.h' and a library `-ldmalloc' and their locations might be
-## specified with the `--with-dmalloc' command-line switch. The value
-## is an include path and/or a library path. If the library path is
-## specified then it must be preceded by a comma.
-##
-AC_SUBST([HAVE_DMALLOC])
-
-## Default is not present
-HAVE_DMALLOC=no
-
-AC_ARG_WITH([dmalloc],
- [AS_HELP_STRING([--with-dmalloc=DIR],
- [Use dmalloc memory debugging aid [default=no]])],,
- [withval=no])
-
-case "X-$withval" in
- X-yes)
- HAVE_DMALLOC="yes"
- AC_CHECK_HEADERS([dmalloc.h],, [unset HAVE_DMALLOC])
- if test "x$HAVE_DMALLOC" = "xyes"; then
- AC_CHECK_LIB([dmalloc], [dmalloc_shutdown],, [unset HAVE_DMALLOC])
- fi
- if test -z "$HAVE_DMALLOC" -a -n "$HDF5_CONFIG_ABORT"; then
- AC_MSG_ERROR([couldn't find dmalloc library])
- fi
- ;;
- X-|X-no|X-none)
- HAVE_DMALLOC="no"
- AC_MSG_CHECKING([for dmalloc library])
- AC_MSG_RESULT([suppressed])
- ;;
- *)
- HAVE_DMALLOC="yes"
- case "$withval" in
- *,*)
- dmalloc_inc="`echo $withval |cut -f1 -d,`"
- dmalloc_lib="`echo $withval |cut -f2 -d, -s`"
- ;;
- *)
- if test -n "$withval"; then
- dmalloc_inc="$withval/include"
- dmalloc_lib="$withval/lib"
- fi
- ;;
- esac
-
- saved_CPPFLAGS="$CPPFLAGS"
- saved_AM_CPPFLAGS="$AM_CPPFLAGS"
- saved_LDFLAGS="$LDFLAGS"
- saved_AM_LDFLAGS="$AM_LDFLAGS"
-
- if test -n "$dmalloc_inc"; then
- CPPFLAGS="$CPPFLAGS -I$dmalloc_inc"
- AM_CPPFLAGS="$AM_CPPFLAGS -I$dmalloc_inc"
- fi
-
- AC_CHECK_HEADERS([dmalloc.h],,[CPPFLAGS="$saved_CPPFLAGS"; AM_CPPFLAGS="$saved_AM_CPPFLAGS"] [unset HAVE_DMALLOC])
-
- if test "x$HAVE_DMALLOC" = "xyes"; then
- if test -n "$dmalloc_lib"; then
- LDFLAGS="$LDFLAGS -L$dmalloc_lib"
- AM_LDFLAGS="$AM_LDFLAGS -L$dmalloc_lib"
- fi
-
- AC_CHECK_LIB([dmalloc], [dmalloc_shutdown],, [LDFLAGS="$saved_LDFLAGS"; AM_LDFLAGS="$saved_AM_LDFLAGS"; unset HAVE_DMALLOC])
- fi
-
- if test -z "$HAVE_DMALLOC" -a -n "$HDF5_CONFIG_ABORT"; then
- AC_MSG_ERROR([couldn't find dmalloc library])
- fi
- ;;
-esac
-
-
-## ----------------------------------------------------------------------
## Make the external filters list available to *.in files
## At this point it's unset (no external filters by default) but it
## will be filled in during the deflate (zlib) and szip processing