summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorjhendersonHDF <jhenderson@hdfgroup.org>2022-04-14 21:19:02 (GMT)
committerGitHub <noreply@github.com>2022-04-14 21:19:02 (GMT)
commitb4090c7c1d4a74273daaabf14717910f203e2f25 (patch)
tree22f820ffb4712611ccb11de0a8957ebfb1a3fde1 /configure.ac
parent9a18a396d21ec2622e62301016f5b912ff4d5a1f (diff)
downloadhdf5-b4090c7c1d4a74273daaabf14717910f203e2f25.zip
hdf5-b4090c7c1d4a74273daaabf14717910f203e2f25.tar.gz
hdf5-b4090c7c1d4a74273daaabf14717910f203e2f25.tar.bz2
Hdf5 1 10 parallel comp (#1644)
* Hdf5 1 10 parallel compression merge
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 10 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 2bf883b..6a1016b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3060,11 +3060,11 @@ if test -n "$PARALLEL"; then
fi
## ----------------------------------------------------------------------
- ## Check for the MPI-3 functions necessary for the Parallel Compression
+ ## Check for the MPI functions necessary for the Parallel Compression
## feature. If these are not present, issue a warning that Parallel
## Compression will be disabled.
##
- AC_MSG_CHECKING([for MPI_Mprobe and MPI_Imrecv functions])
+ AC_MSG_CHECKING([for MPI_Ibarrier/MPI_Issend/MPI_Iprobe/MPI_Irecv functions])
AC_LINK_IFELSE(
[AC_LANG_PROGRAM(
@@ -3072,16 +3072,19 @@ if test -n "$PARALLEL"; then
#include <mpi.h>
]],
[[
- MPI_Message message;
+ int flag;
MPI_Init(0, (void *) 0);
- MPI_Mprobe(0, 0, 0, &message, (void *) 0);
- MPI_Imrecv((void *) 0, 0, 0, (void *) 0, (void *) 0);
+ MPI_Ibarrier(0, (void *) 0);
+ MPI_Issend((void *) 0, 0, 0, 0, 0, 0, (void *) 0);
+ MPI_Iprobe(0, 0, 0, &flag, (void *) 0);
+ MPI_Irecv((void *) 0, 0, 0, 0, 0, 0, (void *) 0);
]]
)],
[AC_MSG_RESULT([yes])
- PARALLEL_FILTERED_WRITES=yes],
+ PARALLEL_FILTERED_WRITES=yes
+ AC_DEFINE([HAVE_PARALLEL_FILTERED_WRITES], [1], [Define if we have support for writing to filtered datasets in parallel])],
[AC_MSG_RESULT([no])
- AC_MSG_WARN([A simple MPI program using the MPI_Mprobe and MPI_Imrecv functions could not be compiled and linked.
+ AC_MSG_WARN([A simple MPI program using the MPI_Ibarrier, MPI_Issend, MPI_Iprobe and MPI_Irecv functions could not be compiled and linked.
Parallel writes of filtered data will be disabled.])
PARALLEL_FILTERED_WRITES=no]
)