summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-07-29 12:20:11 (GMT)
committerGitHub <noreply@github.com>2022-07-29 12:20:11 (GMT)
commitc63dfb0fd3345ecb33014612f94d3959f147be03 (patch)
treefa48ac9cd2023f0182f6e539bd6b5979bbc350f6 /configure.ac
parent3a44ac33203fa8322ab42d3c3e4a0c81134b04e5 (diff)
downloadhdf5-c63dfb0fd3345ecb33014612f94d3959f147be03.zip
hdf5-c63dfb0fd3345ecb33014612f94d3959f147be03.tar.gz
hdf5-c63dfb0fd3345ecb33014612f94d3959f147be03.tar.bz2
fortran module folder from GH#1411 #1922 (#1943)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dd4f8c8..d59409b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -160,6 +160,8 @@ AM_JNIFLAGS="${AM_JNIFLAGS}"
AM_JAVACFLAGS="${AM_JAVACFLAGS}"
AM_JAVAFLAGS="${AM_JAVAFLAGS}"
AM_LDFLAGS="${AM_LDFLAGS}"
+
+## Flags passed in by the user
CFLAGS="${CFLAGS}"
CXXFLAGS="${CXXFLAGS}"
FCFLAGS="${FCFLAGS}"
@@ -615,6 +617,13 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
AC_PROG_FC([PAC_FC_SEARCH_LIST],)
AC_F9X_MODS
+ ## Allow setting the fortran module install dir
+ AC_ARG_WITH([fmoddir],
+ [AS_HELP_STRING([--with-fmoddir=DIR], [Fortran module install directory])],
+ [fmoddir=$withval],
+ [fmoddir="\${includedir}"])
+ AC_SUBST([fmoddir], [$fmoddir])
+
## Change to the Fortran 90 language
AC_LANG_PUSH(Fortran)