summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2021-12-07 20:55:44 (GMT)
committerGitHub <noreply@github.com>2021-12-07 20:55:44 (GMT)
commitd97a4ab2f63a797085c935b487f9a4d658068a79 (patch)
tree98b7fb0015245af8e38d5c47e20436b275b0c1a7 /configure.ac
parent63835409d7e62539cdf25047f5ffb9b88fb252e4 (diff)
downloadhdf5-d97a4ab2f63a797085c935b487f9a4d658068a79.zip
hdf5-d97a4ab2f63a797085c935b487f9a4d658068a79.tar.gz
hdf5-d97a4ab2f63a797085c935b487f9a4d658068a79.tar.bz2
Make default to build high-level tools the same as default for (#1267)
high-level library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b3b7fe5..73485c0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -605,7 +605,7 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
AC_SUBST([OBJECT_NAMELEN_DEFAULT_F])
## --------------------------------------------------------------------
- ## Fortran source extention
+ ## Fortran source extension
##
AC_FC_SRCEXT([f90])
@@ -843,11 +843,14 @@ AC_LANG_POP(C++)
AC_SUBST([HDF5_HL])
AC_SUBST([HDF5_HL_TOOLS])
-## The high-level library is enabled unless the build mode is clean.
+## The high-level library and high-level tools are enabled unless the build mode
+## is clean.
if test "X-$BUILD_MODE" = "X-clean" ; then
HDF5_HL=no
+ HDF5_HL_TOOLS=no
else
HDF5_HL=yes
+ HDF5_HL_TOOLS=yes
fi
## high-level library directories (set when needed, blank until then)