summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-03-20 22:41:53 (GMT)
committerGitHub <noreply@github.com>2023-03-20 22:41:53 (GMT)
commitf1e7081cc28b3af0077af71605df7320aa1b9312 (patch)
tree1873fb4c23c1d55462db723d30736cf65f2eb108 /configure.ac
parent69f3562e312356fe5c58bcc94f0faecdf4af32cf (diff)
downloadhdf5-f1e7081cc28b3af0077af71605df7320aa1b9312.zip
hdf5-f1e7081cc28b3af0077af71605df7320aa1b9312.tar.gz
hdf5-f1e7081cc28b3af0077af71605df7320aa1b9312.tar.bz2
Add Option to not build gif tools and remove javadoc option (#2611)
* Add Option to not build gif tools and remove javadoc option * Remove old option * Fix CMake command format
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 23 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 4a320b3..a649d3d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -846,6 +846,7 @@ AC_LANG_POP(C++)
## library is disabled.
AC_SUBST([HDF5_HL])
AC_SUBST([HDF5_HL_TOOLS])
+AC_SUBST([HDF5_HL_GIF_TOOLS])
## The high-level library and high-level tools are enabled unless the build mode
## is clean.
@@ -886,22 +887,6 @@ else
AC_MSG_RESULT([no])
fi
-AC_MSG_CHECKING([if the high-level tools are enabled])
-AC_ARG_ENABLE([hltools],
- [AS_HELP_STRING([--enable-hltools],
- [Enable the high-level tools.
- [default=yes]
- ])],
- [HDF5_HL_TOOLS=$enableval])
-
-if test "X${HDF5_HL}" = "Xyes" -a "X-$HDF5_HL_TOOLS" = "X-yes"; then
- AC_MSG_RESULT([yes])
- HL_TOOLS="tools"
-else
- AC_MSG_RESULT([no])
-fi
-
-
## ----------------------------------------------------------------------
## Check which archiving tool to use. This needs to be done before
## the LT_INIT macro.
@@ -1161,6 +1146,27 @@ AC_ARG_ENABLE([tools],
AC_MSG_RESULT([$HDF5_TOOLS])
## ----------------------------------------------------------------------
+## Check if they would like to disable building the high-level GIF
+## tools (they have unfixed CVE issues)
+##
+
+AC_MSG_CHECKING([if the high-level GIF tools are enabled])
+AC_ARG_ENABLE([hlgiftools],
+ [AS_HELP_STRING([--enable-hlgiftools],
+ [Enable the high-level GIF tools. NOTE: These have unfixed CVE issues!
+ [default=no]
+ ])],
+ [HDF5_HL_GIF_TOOLS=$enableval])
+
+if test "X-$HDF5_TOOLS" = "X-yes" -a "X-$HDF5_HL" = "X-yes" -a "X-$HDF5_HL_GIF_TOOLS" = "X-yes"; then
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+ HDF5_HL_GIF_TOOLS="no"
+fi
+
+
+## ----------------------------------------------------------------------
## Check if they would like to enable building doxygen files
##
@@ -3881,7 +3887,7 @@ AM_CONDITIONAL([BUILD_HDF5_HL_CONDITIONAL], [test "X$HDF5_HL" = "Xyes"])
AM_CONDITIONAL([BUILD_TESTS_CONDITIONAL], [test "X$HDF5_TESTS" = "Xyes"])
AM_CONDITIONAL([BUILD_TESTS_PARALLEL_CONDITIONAL], [test -n "$TESTPARALLEL"])
AM_CONDITIONAL([BUILD_TOOLS_CONDITIONAL], [test "X$HDF5_TOOLS" = "Xyes"])
-AM_CONDITIONAL([BUILD_TOOLS_HL_CONDITIONAL], [test "X$HDF5_HL_TOOLS" = "Xyes"])
+AM_CONDITIONAL([BUILD_TOOLS_HL_GIF_CONDITIONAL], [test "X$HDF5_HL_GIF_TOOLS" = "Xyes"])
AM_CONDITIONAL([BUILD_DOXYGEN_CONDITIONAL], [test "X$HDF5_DOXYGEN" = "Xyes"])
## ----------------------------------------------------------------------