summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-03-30 18:10:36 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-03-30 18:10:36 (GMT)
commit944cbb940009119de7ccae8a42734b38d03ea2c7 (patch)
treeb9d49b1c9264e988c533a53c3052abf4d292faf5 /configure.ac
parent4c14a0e3db852b6f1e9811a7396d85cc81c85ea8 (diff)
downloadhdf5-944cbb940009119de7ccae8a42734b38d03ea2c7.zip
hdf5-944cbb940009119de7ccae8a42734b38d03ea2c7.tar.gz
hdf5-944cbb940009119de7ccae8a42734b38d03ea2c7.tar.bz2
TRILAB-192 merging warnings changes from develop
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 30 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 54e8caf..ec65386 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,7 +103,11 @@ AC_SUBST([AR_FLAGS])
## H5_CFLAGS (and company) are for CFLAGS that should be used on HDF5, but
## not exported to h5cc (or h5fc, etc.)
+##
+## H5_ECFLAGS is for warnings that should be treated as errors.
+##
AC_SUBST([H5_CFLAGS])
+AC_SUBST([H5_ECFLAGS])
AC_SUBST([H5_CPPFLAGS])
AC_SUBST([H5_FCFLAGS])
AC_SUBST([H5_CXXFLAGS])
@@ -232,6 +236,9 @@ case $host_os in
freebsd*)
host_os_novers=freebsd
;;
+ netbsd*)
+ host_os_novers=netbsd
+ ;;
solaris*)
host_os_novers=solaris
;;
@@ -943,7 +950,7 @@ fi
AM_CONDITIONAL([FORTRAN_SHARED_CONDITIONAL], [test "X$H5_FORTRAN_SHARED" = "Xyes"])
## ----------------------------------------------------------------------
-## Check if they would like to disable building tests
+## Check if they would like to disable building tests
##
## This needs to be exposed for the library info file.
@@ -2938,6 +2945,28 @@ fi
AC_CACHE_SAVE
## ----------------------------------------------------------------------
+## Use custom examples path.
+##
+AC_MSG_CHECKING([for custom examples path definition])
+AC_ARG_WITH([examplesdir],
+ [AS_HELP_STRING([--with-examplesdir=location],
+ [Specify path for examples
+ [default="DATAROOTDIR/hdf5_examples"]])],,
+ withval="${datarootdir}/hdf5_examples")
+
+if test "X$withval" = "X"; then
+ AC_MSG_RESULT([default])
+ examplesdir="${datarootdir}/hdf5_examples"
+else
+ AC_MSG_RESULT([$withval])
+ examplesdir=$withval
+fi
+
+AC_SUBST([examplesdir])
+AC_DEFINE_UNQUOTED([EXAMPLESDIR], ["$examplesdir"],
+ [Define the examples directory])
+
+## ----------------------------------------------------------------------
## Enable custom plugin default path for library. It requires SHARED support.
##
AC_MSG_CHECKING([for custom plugin default path definition])