summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-05-19 00:06:12 (GMT)
committerGitHub <noreply@github.com>2022-05-19 00:06:12 (GMT)
commita6f7dccbd6c6b10ac0051a54bf7e35dedf685861 (patch)
treec1b328163bcf11b6e4a04f593d552494655c6050 /configure.ac
parent63fc02bae8bfc38433cdd45011258901c25c7269 (diff)
downloadhdf5-a6f7dccbd6c6b10ac0051a54bf7e35dedf685861.zip
hdf5-a6f7dccbd6c6b10ac0051a54bf7e35dedf685861.tar.gz
hdf5-a6f7dccbd6c6b10ac0051a54bf7e35dedf685861.tar.bz2
Change TestExpress #1722 (#1777)hdf5_1_10_9-base
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 27 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1e71bf9..08a73bb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -882,7 +882,7 @@ AC_MSG_CHECKING([if the high-level tools are enabled])
AC_ARG_ENABLE([hltools],
[AS_HELP_STRING([--enable-hltools],
[Enable the high-level tools.
- [default=yes)]
+ [default=yes]
])],
[HDF5_HL_TOOLS=$enableval])
@@ -1108,6 +1108,32 @@ AC_SUBST([H5_TEST_BUILDDIR])
H5_TEST_BUILDDIR='test'
## ----------------------------------------------------------------------
+## Check what level of testing should be enabled
+##
+
+## Default is quickest testing
+TEST_EXPRESS_LEVEL_DEFAULT=3
+
+AC_MSG_CHECKING([if HDF5 testing intensity level is set])
+
+AC_ARG_ENABLE([test-express],
+ [AS_HELP_STRING([--enable-test-express=(0-3)],
+ [Set HDF5 testing intensity level (0-3) [0 = exhaustive testing; 3 = quicker testing; default=3] Set environment variable HDF5TestExpress to override configured setting])],
+ [TEST_EXPRESS_LEVEL_DEFAULT=$enableval])
+
+case "X-$TEST_EXPRESS_LEVEL_DEFAULT" in
+ X-0|X-1|X-2|X-3)
+ AC_MSG_RESULT([$TEST_EXPRESS_LEVEL_DEFAULT])
+ ;;
+ *)
+ AC_MSG_RESULT([error])
+ AC_MSG_ERROR([$TEST_EXPRESS_LEVEL_DEFAULT is not a valid test express level])
+ ;;
+esac
+
+AC_DEFINE_UNQUOTED([TEST_EXPRESS_LEVEL_DEFAULT], [$TEST_EXPRESS_LEVEL_DEFAULT], [HDF5 testing intensity level])
+
+## ----------------------------------------------------------------------
## Check if they would like to disable building tools
##