summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2021-01-11 02:29:34 (GMT)
committerGitHub <noreply@github.com>2021-01-11 02:29:34 (GMT)
commitef6421ffc7809a0670836f68f5163c6ee33726d0 (patch)
tree86a1e19ecc218ed2ea2a8036d329ed2ea55a727a /configure.ac
parent0a7296663b49ce4710ebe57a7ceae21fa3571ff1 (diff)
downloadhdf5-ef6421ffc7809a0670836f68f5163c6ee33726d0.zip
hdf5-ef6421ffc7809a0670836f68f5163c6ee33726d0.tar.gz
hdf5-ef6421ffc7809a0670836f68f5163c6ee33726d0.tar.bz2
Stat st blocks fix 110 (#249)
* close #195. (#196) * Update HDF5PluginMacros.cmake * Update HDF5PluginMacros.cmake * Modify temporary rpath for testing in java example scripts. (#230) * Fixes Autotools detection of the st_blocks field in stat (#246) * Fixes Autotools detection of the st_blocks field in stat The Autotools and CMake will now both correctly determine if the stat struct has the st_blocks field and set H5_HAVE_STAT_ST_BLOCKS appropriately. * Fixes a typo in configure.ac Co-authored-by: H. Joe Lee <hyoklee@hdfgroup.org> Co-authored-by: Dana Robinson <43805+derobins@users.noreply.github.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fcafdbb..e91f06f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1962,10 +1962,10 @@ esac
## ----------------------------------------------------------------------
-## Does the struct stat have the st_blocks field? This field is not Posix.
+## Does the struct stat have the st_blocks field? This field is not POSIX.
##
AC_MSG_CHECKING([for st_blocks in struct stat])
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM[[
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <sys/stat.h>]],[[struct stat sb; sb.st_blocks=0;]])],
[AC_DEFINE([HAVE_STAT_ST_BLOCKS], [1],
[Define if struct stat has the st_blocks field])