summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-05-20 17:07:09 (GMT)
committerGitHub <noreply@github.com>2022-05-20 17:07:09 (GMT)
commit4466a30825eda620a00e5d8fac35ecf765296aad (patch)
tree84497284f2a6c6558a02329512f379328fdbdfa9 /configure.ac
parent60820abcbef0cd4efa23cabacc728c088aebf554 (diff)
downloadhdf5-4466a30825eda620a00e5d8fac35ecf765296aad.zip
hdf5-4466a30825eda620a00e5d8fac35ecf765296aad.tar.gz
hdf5-4466a30825eda620a00e5d8fac35ecf765296aad.tar.bz2
Change TestExpress #1722 (#1776)
* Change TestExpress #1722 * Update comment
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5fe09b8..b3ba87c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1126,6 +1126,32 @@ AC_SUBST([H5_TEST_BUILDDIR])
H5_TEST_BUILDDIR='test'
## ----------------------------------------------------------------------
+## Check what level of testing should be enabled
+##
+
+## Default is quickest testing
+TEST_EXPRESS_LEVEL_DEFAULT=3
+
+AC_MSG_CHECKING([if HDF5 testing intensity level is set])
+
+AC_ARG_ENABLE([test-express],
+ [AS_HELP_STRING([--enable-test-express],
+ [Set HDF5 testing intensity level (0-3) [0 = exhaustive testing; 3 = quicker testing; default=3]])],
+ [TEST_EXPRESS_LEVEL_DEFAULT=$enableval])
+
+case "X-$TEST_EXPRESS_LEVEL_DEFAULT" in
+ X-0|X-1|X-2|X-3)
+ AC_MSG_RESULT([$TEST_EXPRESS_LEVEL_DEFAULT])
+ ;;
+ *)
+ AC_MSG_RESULT([error])
+ AC_MSG_ERROR([$TEST_EXPRESS_LEVEL_DEFAULT is not a valid test express level])
+ ;;
+esac
+
+AC_DEFINE_UNQUOTED([TEST_EXPRESS_LEVEL_DEFAULT], [$TEST_EXPRESS_LEVEL_DEFAULT], [HDF5 testing intensity level])
+
+## ----------------------------------------------------------------------
## Check if they would like to disable building tools
##