summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Warren <Richard.Warren@hdfgroup.org>2019-12-06 21:42:36 (GMT)
committerRichard Warren <Richard.Warren@hdfgroup.org>2019-12-06 21:42:36 (GMT)
commit0c06cfc6ef9d851908f1017881598628ddf70b2a (patch)
tree0046503ba9371adcf6ad33a307d6e6827e52d88a /configure.ac
parent9d24eefaf71bae79ab3e483a608ddb8deff17b39 (diff)
downloadhdf5-0c06cfc6ef9d851908f1017881598628ddf70b2a.zip
hdf5-0c06cfc6ef9d851908f1017881598628ddf70b2a.tar.gz
hdf5-0c06cfc6ef9d851908f1017881598628ddf70b2a.tar.bz2
Merged HDFFV-10929_2GB_testing to hdf5_1_12
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 38 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 9898005..edb6de3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,7 +103,11 @@ AC_SUBST([AR_FLAGS])
## H5_CFLAGS (and company) are for CFLAGS that should be used on HDF5, but
## not exported to h5cc (or h5fc, etc.)
+##
+## H5_ECFLAGS is for warnings that should be treated as errors.
+##
AC_SUBST([H5_CFLAGS])
+AC_SUBST([H5_ECFLAGS])
AC_SUBST([H5_CPPFLAGS])
AC_SUBST([H5_FCFLAGS])
AC_SUBST([H5_CXXFLAGS])
@@ -232,6 +236,9 @@ case $host_os in
freebsd*)
host_os_novers=freebsd
;;
+ netbsd*)
+ host_os_novers=netbsd
+ ;;
solaris*)
host_os_novers=solaris
;;
@@ -2964,6 +2971,28 @@ fi
AC_CACHE_SAVE
## ----------------------------------------------------------------------
+## Use custom examples path.
+##
+AC_MSG_CHECKING([for custom examples path definition])
+AC_ARG_WITH([examplesdir],
+ [AS_HELP_STRING([--with-examplesdir=location],
+ [Specify path for examples
+ [default="DATAROOTDIR/hdf5_examples"]])],,
+ withval="${datarootdir}/hdf5_examples")
+
+if test "X$withval" = "X"; then
+ AC_MSG_RESULT([default])
+ examplesdir="${datarootdir}/hdf5_examples"
+else
+ AC_MSG_RESULT([$withval])
+ examplesdir=$withval
+fi
+
+AC_SUBST([examplesdir])
+AC_DEFINE_UNQUOTED([EXAMPLESDIR], ["$examplesdir"],
+ [Define the examples directory])
+
+## ----------------------------------------------------------------------
## Enable custom plugin default path for library. It requires SHARED support.
##
AC_MSG_CHECKING([for custom plugin default path definition])
@@ -3390,10 +3419,10 @@ esac
AC_SUBST([DEFAULT_API_VERSION])
AC_MSG_CHECKING([which version of public symbols to use by default])
AC_ARG_WITH([default-api-version],
- [AS_HELP_STRING([--with-default-api-version=(v16|v18|v110|v112)],
+ [AS_HELP_STRING([--with-default-api-version=(v16|v18|v110|v112|v114)],
[Specify default release version of public symbols
- [default=v112]])],,
- [withval=v112])
+ [default=v114]])],,
+ [withval=v114])
if test "X$withval" = "Xv16"; then
AC_MSG_RESULT([v16])
@@ -3415,6 +3444,11 @@ elif test "X$withval" = "Xv112"; then
DEFAULT_API_VERSION=v112
AC_DEFINE([USE_112_API_DEFAULT], [1],
[Define using v1.12 public API symbols by default])
+elif test "X$withval" = "Xv114"; then
+ AC_MSG_RESULT([v114])
+ DEFAULT_API_VERSION=v114
+ AC_DEFINE([USE_114_API_DEFAULT], [1],
+ [Define using v1.14 public API symbols by default])
else
AC_MSG_ERROR([invalid version of public symbols given])
fi
@@ -3424,7 +3458,7 @@ fi
## if the user insists on doing this via the --enable-unsupported configure
## flag, we'll let them.
if test "X${ALLOW_UNSUPPORTED}" != "Xyes"; then
- if test "X${DEFAULT_API_VERSION}" != "Xv112" -a "X${DEPRECATED_SYMBOLS}" = "Xno" ; then
+ if test "X${DEFAULT_API_VERSION}" != "Xv114" -a "X${DEPRECATED_SYMBOLS}" = "Xno" ; then
AC_MSG_ERROR([Removing old public API symbols not allowed when using them as default public API symbols. Use --enable-unsupported to override this error.])
fi
fi