summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2015-04-21 16:57:33 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2015-04-21 16:57:33 (GMT)
commit11b19627b9ac9a97af2970dac92e378baeb9fc1e (patch)
tree78988ac90fce00ca5270c93d47a7d5235e97efe5 /configure.ac
parent6813b25007280afa9b8bec13c19c134029acd26c (diff)
parentb32caab787236a72c25dcb1c895c32da8832deab (diff)
downloadhdf5-11b19627b9ac9a97af2970dac92e378baeb9fc1e.zip
hdf5-11b19627b9ac9a97af2970dac92e378baeb9fc1e.tar.gz
hdf5-11b19627b9ac9a97af2970dac92e378baeb9fc1e.tar.bz2
[svn-r26867] svn merge -r26837:26866 https://svn.hdfgroup.uiuc.edu/hdf5/trunk
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 14b4335..aaaceb3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -647,6 +647,19 @@ AC_SUBST([RUNPARALLEL])
AC_SUBST([TESTPARALLEL])
## ----------------------------------------------------------------------
+## Disable shared libraries on CYGWIN. (LK - 04/16/15)
+## A number of tests run by "make check" fail on CYGWIN, so for HDF5 v1.8.15
+## we will change the default for shared libraries to disabled.
+
+
+case "`uname`" in
+ CYGWIN*)
+ enable_shared="no"
+ CHECK_WARN="Shared libraries are not currently supported on CYGWIN."
+ ;;
+esac
+
+## ----------------------------------------------------------------------
## Fortran libraries are not currently supported on Mac. Disable them.
## (this is overridable with --enable-unsupported).
##
@@ -697,6 +710,8 @@ LT_PREREQ([2.2])
## win32-dll - This will build clean dlls on win32 platforms.
LT_INIT([dlopen,win32-dll])
+
+
## ----------------------------------------------------------------------
## Check if we should install only statically linked executables.
## This check needs to occur after libtool is initialized because
@@ -2909,5 +2924,11 @@ cat >> src/H5config.h <<EOF
#endif
EOF
+## HDF5 configure code created by autotools with gcc 4.9.2 is adding problematic
+## linker flags: -l with no library name; -l <libname>, specifically gfortran or m.
+## This sed script corrects "-l <libname>" first and then "-l " with no library name.
+## If the order is not preserved, all instances of "-l " will be removed.
+sed -e '/^postdeps/ s/-l \([a-zA-Z]\)/-l\1/g' -e '/^postdeps/ s/-l //g' -i libtool
+
## show the configure settings
cat src/libhdf5.settings