summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2017-06-28 23:36:26 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2017-06-28 23:36:26 (GMT)
commit373de3f95feaa3d1a06a351a634109a7828cdb6e (patch)
tree33c1568e4847c79d69331ad219c153058614a908 /configure.ac
parent25727c4f2cfea0230f236bc62f295c9a59172cc3 (diff)
downloadhdf5-373de3f95feaa3d1a06a351a634109a7828cdb6e.zip
hdf5-373de3f95feaa3d1a06a351a634109a7828cdb6e.tar.gz
hdf5-373de3f95feaa3d1a06a351a634109a7828cdb6e.tar.bz2
Added awk processing to remove extraneous whitespace from H5_
flags in configure.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3eaf293..cc91682 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3352,6 +3352,14 @@ fi
##
AM_CONDITIONAL([HAVE_SHARED_CONDITIONAL], [test "X$enable_shared" = "Xyes"])
+## The H5 flags go through multiple rounds of processing, which can introduce
+## extra whitespace. Trim this for nicer output in the settings file.
+H5_LDFLAGS=$(echo "$H5_LDFLAGS" | awk '$1=$1')
+H5_CPPFLAGS=$(echo "$H5_CPPFLAGS" | awk '$1=$1')
+H5_CFLAGS=$(echo "$H5_CFLAGS" | awk '$1=$1')
+H5_FCFLAGS=$(echo "$H5_FCFLAGS" | awk '$1=$1')
+H5_CXXFLAGS=$(echo "$H5_CXXFLAGS" | awk '$1=$1')
+
AC_CONFIG_FILES([src/libhdf5.settings
Makefile
src/Makefile