summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorM. Scot Breitenfeld <brtnfld@hdfgroup.org>2017-05-23 14:53:59 (GMT)
committerM. Scot Breitenfeld <brtnfld@hdfgroup.org>2017-05-23 14:53:59 (GMT)
commit69ccaee00a2778c7334587b6f6d51e16ff674ec9 (patch)
tree12a9575d5c05dd194a21446a2086acc9a35b04f0 /configure.ac
parent6301d5a6cb7527f7f2eed0d60d1faaf154ed9976 (diff)
downloadhdf5-69ccaee00a2778c7334587b6f6d51e16ff674ec9.zip
hdf5-69ccaee00a2778c7334587b6f6d51e16ff674ec9.tar.gz
hdf5-69ccaee00a2778c7334587b6f6d51e16ff674ec9.tar.bz2
add documention comments for shared Fortran Fix on OSX
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index b6f37bc..9695fe3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -918,12 +918,13 @@ H5_FORTRAN_SHARED="no"
if test "X${HDF_FORTRAN}" = "Xyes" && test "X${enable_shared}" != "Xno"; then
AC_MSG_CHECKING([if shared Fortran libraries are supported])
H5_FORTRAN_SHARED="yes"
-
- ## tell libtool to do the right thing with COMMON symbols
+ ## tell libtool to do the right thing with COMMON symbols, this fixes
+ ## corrupt values with COMMON and EQUIVALENCE when building shared
+ ## Fortran libraries on OSX with gnu and Intel compilers (HDFFV-2772).
case "`uname`" in
Darwin*)
H5_LDFLAGS="$H5_LDFLAGS -Wl,-commons,use_dylibs"
- ;;
+ ;;
esac
## Report results of check(s)
@@ -3482,8 +3483,9 @@ chmod 755 tools/src/misc/h5cc
if test "X$HDF_FORTRAN" = "Xyes"; then
chmod 755 fortran/src/h5fc
- ## tell libtool to pass the correct argument linker, needed only for intel compiler. This script
- ## replaces the 3rd occurance, which is for Fortran, of wl="" with wl="-Wl,"
+ ## libtool does not pass the correct argument linker (wl=) for the Intel Fortran compiler
+ ## on OS X, which is needed when building shared libraries on OS X. This script
+ ## replaces the 3rd occurrence, which is for Fortran, of wl="" with wl="-Wl," (HDFFV-2772)
case "`uname`" in
Darwin*)
cat libtool | awk '/wl=\"/{c++;if(c==3){sub("wl=\"\"","wl=\"-Wl,\"");c=0}}1' > libtool.tmp && mv -f libtool.tmp libtool && chmod 755 libtool