summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2022-06-30 13:59:03 (GMT)
committerGitHub <noreply@github.com>2022-06-30 13:59:03 (GMT)
commit72db748dd996b463daf7896d287417c97149c5ac (patch)
tree7da6bc7ae805244231628d1654debf30bea31f49 /configure.ac
parent89fae896aeec488a7d3acc8a1b0974115cb4ead6 (diff)
downloadhdf5-72db748dd996b463daf7896d287417c97149c5ac.zip
hdf5-72db748dd996b463daf7896d287417c97149c5ac.tar.gz
hdf5-72db748dd996b463daf7896d287417c97149c5ac.tar.bz2
Updates the MinGW configure.ac check for the Winsock library (#1837)
Ubuntu 22.04 complains about AC_HAVE_LIBRARY being deprecated. This updates the macro to AC_CHECK_LIB, where the specified function is GetUserName(). This change only affects MinGW
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 575628f..c25b711 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1352,7 +1352,8 @@ esac
## Windows
case "`uname`" in
MINGW*)
- AC_HAVE_LIBRARY([ws2_32])
+ # The Winsock library
+ AC_CHECK_LIB([ws2_32], [GetUserName])
;;
esac