summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-07-26 16:02:40 (GMT)
committerGitHub <noreply@github.com>2022-07-26 16:02:40 (GMT)
commit06363958513ad26b2c21cd99858183c97e6d223a (patch)
tree941a6beb2c1372f1955562c6712fd91c22be834b /configure.ac
parentb0240030f5dd1c3da65fd66b76fcdfe13604489c (diff)
downloadhdf5-06363958513ad26b2c21cd99858183c97e6d223a.zip
hdf5-06363958513ad26b2c21cd99858183c97e6d223a.tar.gz
hdf5-06363958513ad26b2c21cd99858183c97e6d223a.tar.bz2
Implement improved CMake fortran module folder from GH#1411 (#1922)
* Implement improved CMake fortran module folder from GH#1411 * Update docs * Fix whitespace * Fix name case
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7afdc53..5b1ecb5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -618,6 +618,13 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
AC_PROG_FC([PAC_FC_SEARCH_LIST],)
AC_F9X_MODS
+ ## Allow setting the fortran module install dir
+ AC_ARG_WITH([fmoddir],
+ [AS_HELP_STRING([--with-fmoddir=DIR], [Fortran module install directory])],
+ [fmoddir=$withval],
+ [fmoddir="\${includedir}"])
+ AC_SUBST([fmoddir], [$fmoddir])
+
## Change to the Fortran 90 language
AC_LANG_PUSH(Fortran)