summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-05-17 16:54:05 (GMT)
committerGitHub <noreply@github.com>2022-05-17 16:54:05 (GMT)
commit081b3902bfd2d5ffbf7a2925db2a9ff802288579 (patch)
tree0426cd1de6b5e7ab8787931a4e8982d65d31f584 /configure.ac
parente7b184e79ec489ae7a373840a75ec45ea355d635 (diff)
downloadhdf5-081b3902bfd2d5ffbf7a2925db2a9ff802288579.zip
hdf5-081b3902bfd2d5ffbf7a2925db2a9ff802288579.tar.gz
hdf5-081b3902bfd2d5ffbf7a2925db2a9ff802288579.tar.bz2
Set default level to minimum time (#1722)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d2d6441..0d8585a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1120,6 +1120,32 @@ AC_SUBST([H5_TEST_BUILDDIR])
H5_TEST_BUILDDIR='test'
## ----------------------------------------------------------------------
+## Check what level of testing should be enabled
+##
+
+## Default is quickest testing
+TEST_EXPRESS_LEVEL_DEFAULT=3
+
+AC_MSG_CHECKING([if HDF5 testing intensity level is set])
+
+AC_ARG_ENABLE([test-express],
+ [AS_HELP_STRING([--enable-test-express],
+ [Set HDF5 testing intensity level (0-3) [0 = exhaustive testing; 3 = quicker testing; default=3]])],
+ [TEST_EXPRESS_LEVEL_DEFAULT=$enableval])
+
+case "X-$TEST_EXPRESS_LEVEL_DEFAULT" in
+ X-0|X-1|X-2|X-3)
+ AC_MSG_RESULT([$TEST_EXPRESS_LEVEL_DEFAULT])
+ ;;
+ *)
+ AC_MSG_RESULT([error])
+ AC_MSG_ERROR([$TEST_EXPRESS_LEVEL_DEFAULT is not a valid test express level])
+ ;;
+esac
+
+AC_DEFINE_UNQUOTED([TEST_EXPRESS_LEVEL_DEFAULT], [$TEST_EXPRESS_LEVEL_DEFAULT], [HDF5 testing intensity level])
+
+## ----------------------------------------------------------------------
## Check if they would like to disable building tools
##