summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2021-12-10 05:06:53 (GMT)
committerGitHub <noreply@github.com>2021-12-10 05:06:53 (GMT)
commit5580d7ec815e506370c4b1d68fc5ed089442e15d (patch)
tree5416be32e3251eeb809c1f16781d3e22644536f2 /configure.ac
parent364d8cc3e749bcee4486897b6703f9ac7a303225 (diff)
downloadhdf5-5580d7ec815e506370c4b1d68fc5ed089442e15d.zip
hdf5-5580d7ec815e506370c4b1d68fc5ed089442e15d.tar.gz
hdf5-5580d7ec815e506370c4b1d68fc5ed089442e15d.tar.bz2
Fix directory variable in shell scripts (#1273)
* Fix testswmr scripts with utils/test variable * Change format of configure var assignment * quote the variable value in configure * Use sh.in expected var pattern * Only ref builddir in script * Create vars for utils/test and test as H5_<path>_BUILDDIR * Use abs_top_builddir in test scripts * Change script var to make it easier to read. * Use @abs_top_builddir@ directly in paths * Correct typos/comment
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 31578a6..556e565 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1122,6 +1122,12 @@ else
AC_MSG_RESULT([no])
fi
+## These need to be exposed for some tests.
+AC_SUBST([H5_UTILS_TEST_BUILDDIR])
+H5_UTILS_TEST_BUILDDIR='utils/test'
+AC_SUBST([H5_TEST_BUILDDIR])
+H5_TEST_BUILDDIR='test'
+
## ----------------------------------------------------------------------
## Check if they would like to disable building tools
##
@@ -1686,7 +1692,7 @@ fi
## command-line switch. The value is an include path and/or a library path.
## If the library path is specified then it must be preceded by a comma.
##
-AC_SUBST([LL_PATH])
+AC_SUBST([LL_PATH])
AC_SUBST([USE_FILTER_SZIP]) USE_FILTER_SZIP="no"
AC_ARG_WITH([szlib],
[AS_HELP_STRING([--with-szlib=DIR],
@@ -3037,7 +3043,7 @@ if test -n "$PARALLEL"; then
fi
## ----------------------------------------------------------------------
-## Build parallel tools if parallel tools, parallel, and build tools options
+## Build parallel tools if parallel tools, parallel, and build tools options
## are all enabled.
##
AC_SUBST([PARALLEL_TOOLS])
@@ -3057,7 +3063,7 @@ if test "X${PARALLEL_TOOLS}" = "Xyes"; then
AC_MSG_ERROR([--enable-tools is required for --enable-parallel-tools])
fi
if test "X${PARALLEL}" != "Xyes"; then
- AC_MSG_ERROR([--enable-parallel is required for --enable-parallel-tools])
+ AC_MSG_ERROR([--enable-parallel is required for --enable-parallel-tools])
fi
fi