summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2021-01-11 02:30:12 (GMT)
committerGitHub <noreply@github.com>2021-01-11 02:30:12 (GMT)
commitb92dcf3a6535fc14a6fdc7afb290eb16f1ec8b38 (patch)
treebc2e00776bc53f1cdb34de14ca4e90f03e39a781 /configure.ac
parentfde0d6c021f9cdfcb0338fd953a49bf2c9ab52e6 (diff)
downloadhdf5-b92dcf3a6535fc14a6fdc7afb290eb16f1ec8b38.zip
hdf5-b92dcf3a6535fc14a6fdc7afb290eb16f1ec8b38.tar.gz
hdf5-b92dcf3a6535fc14a6fdc7afb290eb16f1ec8b38.tar.bz2
Stat st blocks fix 18 (#250)
* close #195. (#196) * Update HDF5PluginMacros.cmake * Update HDF5PluginMacros.cmake * Restores maintainer mode in the autotools (#200) Maintainer mode should be enabled in development branches. Also adds helpful commenting. Add script bin/switch_maint_mode. Add file changes generated by bin reconfigure in src/H5Edefin.h src/H5Einit.h src/H5Epubgen.h src/H5Eterm.h * Update MANIFEST for switch_maint_mode. * Update so numbers to match 1.8.22 release. * Fixes Autotools detection of the st_blocks field in stat (#246) * Fixes Autotools detection of the st_blocks field in stat The Autotools and CMake will now both correctly determine if the stat struct has the st_blocks field and set H5_HAVE_STAT_ST_BLOCKS appropriately. * Fixes a typo in configure.ac Co-authored-by: H. Joe Lee <hyoklee@hdfgroup.org> Co-authored-by: Dana Robinson <43805+derobins@users.noreply.github.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3464d0a..72c4333 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1685,10 +1685,10 @@ esac
## ----------------------------------------------------------------------
-## Does the struct stat have the st_blocks field? This field is not Posix.
+## Does the struct stat have the st_blocks field? This field is not POSIX.
##
AC_MSG_CHECKING([for st_blocks in struct stat])
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM[[
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <sys/stat.h>]],[[struct stat sb; sb.st_blocks=0;]])],
[AC_DEFINE([HAVE_STAT_ST_BLOCKS], [1],
[Define if struct stat has the st_blocks field])