summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2021-10-22 15:03:51 (GMT)
committerGitHub <noreply@github.com>2021-10-22 15:03:51 (GMT)
commit223b3765293852c94b84e5b40c7585ecc5021eaa (patch)
tree177ff342ca25f489311a3d84bfcb0a8cb5a105b5 /configure.ac
parente5e108dbd56fc1b871915d3de64fe85a6fc9b175 (diff)
downloadhdf5-223b3765293852c94b84e5b40c7585ecc5021eaa.zip
hdf5-223b3765293852c94b84e5b40c7585ecc5021eaa.tar.gz
hdf5-223b3765293852c94b84e5b40c7585ecc5021eaa.tar.bz2
1.8 Merge cmake and flag changes from develop (#1119)
* Merge cmake and flag changes from develop * Committing clang-format changes Co-authored-by: github-actions <41898282+github-actions[bot]@users.noreply.github.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac84
1 files changed, 84 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a0ee2bd..5256f3d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -881,6 +881,89 @@ else
fi
## ----------------------------------------------------------------------
+## Check if they would like to enable building doxygen files
+##
+
+## This needs to be exposed for the library info file.
+AC_SUBST([HDF5_DOXYGEN])
+
+## Default is to not build DOXYGEN
+HDF5_DOXYGEN=no
+
+AC_MSG_CHECKING([if building doxygen is enabled])
+
+AC_ARG_ENABLE([doxygen],
+ [AS_HELP_STRING([--enable-doxygen],
+ [Compile the HDF5 doxygen files [default=no]])],
+ [HDF5_DOXYGEN=$enableval])
+
+if test "X$HDF5_DOXYGEN" = "Xyes"; then
+ AC_MSG_RESULT([yes])
+ DX_DOXYGEN_FEATURE(ON)
+ DX_DOT_FEATURE(OFF)
+ DX_HTML_FEATURE(ON)
+ DX_CHM_FEATURE(OFF)
+ DX_CHI_FEATURE(OFF)
+ DX_MAN_FEATURE(ON)
+ DX_RTF_FEATURE(OFF)
+ DX_XML_FEATURE(OFF)
+ DX_PDF_FEATURE(OFF)
+ DX_PS_FEATURE(OFF)
+
+ AC_SUBST([DOXYGEN_PACKAGE])
+ AC_SUBST([DOXYGEN_VERSION_STRING])
+ AC_SUBST([DOXYGEN_INCLUDE_ALIASES])
+ AC_SUBST([DOXYGEN_PROJECT_LOGO])
+ AC_SUBST([DOXYGEN_PROJECT_BRIEF])
+ AC_SUBST([DOXYGEN_INPUT_DIRECTORY])
+ AC_SUBST([DOXYGEN_OPTIMIZE_OUTPUT_FOR_C])
+ AC_SUBST([DOXYGEN_MACRO_EXPANSION])
+ AC_SUBST([DOXYGEN_OUTPUT_DIRECTORY])
+ AC_SUBST([DOXYGEN_EXAMPLES_DIRECTORY])
+ AC_SUBST([DOXYGEN_LAYOUT_FILE])
+ AC_SUBST([DOXYGEN_HTML_HEADER])
+ AC_SUBST([DOXYGEN_HTML_FOOTER])
+ AC_SUBST([DOXYGEN_HTML_EXTRA_STYLESHEET])
+ AC_SUBST([DOXYGEN_HTML_EXTRA_FILES])
+ AC_SUBST([DOXYGEN_TAG_FILE])
+ AC_SUBST([DOXYGEN_SERVER_BASED_SEARCH])
+ AC_SUBST([DOXYGEN_EXTERNAL_SEARCH])
+ AC_SUBST([DOXYGEN_SEARCHENGINE_URL])
+ AC_SUBST([DOXYGEN_STRIP_FROM_PATH])
+ AC_SUBST([DOXYGEN_PREDEFINED])
+
+# SRCDIR Environment variables used inside doxygen macro for the source location:
+ DOXYGEN_PACKAGE=${PACKAGE_NAME}
+ DOXYGEN_VERSION_STRING=${PACKAGE_VERSION}
+ DOXYGEN_INCLUDE_ALIASES='$(SRCDIR)/doxygen/aliases'
+ DOXYGEN_PROJECT_LOGO='$(SRCDIR)/doxygen/img/HDFG-logo.png'
+ DOXYGEN_PROJECT_BRIEF='C-API Reference'
+ DOXYGEN_INPUT_DIRECTORY='$(SRCDIR) $(SRCDIR)/doxygen/dox'
+ DOXYGEN_OPTIMIZE_OUTPUT_FOR_C=YES
+ DOXYGEN_MACRO_EXPANSION=YES
+ DOXYGEN_OUTPUT_DIRECTORY=hdf5lib_docs
+ DOXYGEN_EXAMPLES_DIRECTORY='$(SRCDIR)/doxygen/dox/cookbook $(SRCDIR)/doxygen/examples $(SRCDIR)/src $(SRCDIR)/examples $(SRCDIR)/test'
+ DOXYGEN_LAYOUT_FILE='$(SRCDIR)/doxygen/hdf5doxy_layout.xml'
+ DOXYGEN_HTML_HEADER='$(SRCDIR)/doxygen/hdf5_header.html'
+ DOXYGEN_HTML_FOOTER='$(SRCDIR)/doxygen/hdf5_footer.html'
+ DOXYGEN_HTML_EXTRA_STYLESHEET='$(SRCDIR)/doxygen/hdf5doxy.css'
+ DOXYGEN_HTML_EXTRA_FILES='$(SRCDIR)/doxygen/hdf5_navtree_hacks.js $(SRCDIR)/doxygen/img/ftv2node.png $(SRCDIR)/doxygen/img/ftv2pnode.png'
+ DOXYGEN_TAG_FILE=hdf5.tag
+ DOXYGEN_SERVER_BASED_SEARCH=NO
+ DOXYGEN_EXTERNAL_SEARCH=NO
+ DOXYGEN_SEARCHENGINE_URL=
+ DOXYGEN_STRIP_FROM_PATH='$(SRCDIR)'
+ DOXYGEN_PREDEFINED='H5_HAVE_DIRECT H5_HAVE_LIBHDFS H5_HAVE_MAP_API H5_HAVE_PARALLEL H5_HAVE_ROS3_VFD'
+
+ DX_INIT_DOXYGEN([HDF5], [./doxygen/Doxyfile], [hdf5lib_docs])
+
+else
+ AC_MSG_RESULT([no])
+ echo "Doxygen support is disabled"
+fi
+
+
+## ----------------------------------------------------------------------
## Create libtool. If shared/static libraries are going to be enabled
## or disabled, it should happen before these macros.
LT_PREREQ([2.2])
@@ -3601,6 +3684,7 @@ AM_CONDITIONAL([HAVE_SHARED_CONDITIONAL], [test "X$enable_shared" = "Xyes"])
AC_CONFIG_FILES([src/libhdf5.settings
Makefile
+ doxygen/Doxyfile
src/Makefile
test/Makefile
test/testcheck_version.sh