summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2013-04-24 18:27:27 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2013-04-24 18:27:27 (GMT)
commit72801adb88f2c099bc019bec8fca42c351a96b3f (patch)
tree98621341b14f4f62a65b8a048aeba00afb8d8f31 /configure.ac
parent32a116458a77d713521053bd774c98f572d18abe (diff)
downloadhdf5-72801adb88f2c099bc019bec8fca42c351a96b3f.zip
hdf5-72801adb88f2c099bc019bec8fca42c351a96b3f.tar.gz
hdf5-72801adb88f2c099bc019bec8fca42c351a96b3f.tar.bz2
[svn-r23619] Bug fix: HDFFV-8390
Threadsafe works in v1.8.10 release. But it fails v1.8.11-pre1 tarball in configure stage now. There was a typo in the configure around the checking of pthread library. Fixed it. Tested: AIX and also h5committested.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index bff8b04..2ff93a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1977,7 +1977,7 @@ AC_ARG_WITH([pthread],
case "$withval" in
yes)
AC_CHECK_HEADERS([pthread.h],, [unset HAVE_PTHREAD])
- if test "x$HAVE_DMALLOC" = "xyes"; then
+ if test "x$HAVE_PTHREAD" = "xyes"; then
AC_CHECK_LIB([pthread], [pthread_self],, [unset HAVE_PTHREAD])
fi
;;
@@ -2019,7 +2019,7 @@ case "$withval" in
AC_CHECK_HEADERS([pthread.h],, [unset HAVE_PTHREAD])
fi
- if test "x$HAVE_DMALLOC" = "xyes"; then
+ if test "x$HAVE_PTHREAD" = "xyes"; then
if test -n "$pthread_lib"; then
saved_LDFLAGS="$LDFLAGS"
saved_AM_LDFLAGS="$AM_LDFLAGS"