summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2015-03-11 04:59:20 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2015-03-11 04:59:20 (GMT)
commit9afdf275f8f0719073f558c465962e44a65b9aae (patch)
tree01b1d9953033422b1b7dbfca7788479e590d7911 /configure.ac
parentbdb7ec34976ea549e13feced52942ec9c8908616 (diff)
downloadhdf5-9afdf275f8f0719073f558c465962e44a65b9aae.zip
hdf5-9afdf275f8f0719073f558c465962e44a65b9aae.tar.gz
hdf5-9afdf275f8f0719073f558c465962e44a65b9aae.tar.bz2
[svn-r26423] Made the thread-safe + high-level library combination "unsupported".
A detailed error message is emitted if this combination is attempted. Builders can use --enable-unsupported to build the combo. Note that default builds will now need to use --disable-hl with --enable-threadsafe since the high-level library is built by default. Part of: HDFFV-8719 Tested on: Local Linux w/ various combinations of configure options.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eae0f0b..788e862 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1508,6 +1508,17 @@ AC_ARG_ENABLE([threadsafe],
## with the thread-safety option because the lock is not hoisted
## into the higher-level API calls.
+## --enable-threadsafe is incompatible with --enable-hl unless
+## --enable-unsupported has been specified on the configure line.
+##
+## Note that the high-level library is enabled by default so most
+## users will have to add --disable-hl to the configure options.
+if test "X${ALLOW_UNSUPPORTED}" != "Xyes"; then
+ if test "X${HDF5_HL}" = "Xyes" -a "X${enable_threadsafe}" = "Xyes"; then
+ AC_MSG_ERROR([The thread-safe library is incompatible with the high-level library. --enable-unsupported will allow building the high-level library, though this configuration is not supported by The HDF Group. Alternatively,--disable-hl can be used to prevent building the high-level library (recommended).])
+ fi
+fi
+
## The --enable-threadsafe flag is not compatible with --enable-cxx.
## If the user tried to specify both flags, throw an error, unless
## they also provided the --enable-unsupported flag.