summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2015-03-19 22:22:06 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2015-03-19 22:22:06 (GMT)
commit9fb399b3d2c071f273279be81317be53a084d073 (patch)
tree96f4e61cdff17cb22379248617f040a8e7dfa77e /configure.ac
parent5329a7d6f1e4323636489f896621be0c3167486f (diff)
downloadhdf5-9fb399b3d2c071f273279be81317be53a084d073.zip
hdf5-9fb399b3d2c071f273279be81317be53a084d073.tar.gz
hdf5-9fb399b3d2c071f273279be81317be53a084d073.tar.bz2
[svn-r26495] Description:
Bring r26258 from the autotools_rework branch to the trunk - remove the LDOUBLE_TO_INTEGER_WORKS macro/define, which was addressing issues with SGI systems that are no longer supported. Tested on: Linux 2.6.x (jam) w/serial & parallel Daily tested on branch for >2 weeks
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 0 insertions, 47 deletions
diff --git a/configure.ac b/configure.ac
index 1f93072..df48104 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2558,53 +2558,6 @@ case "`uname`" in
esac
## -----------------------------------------------------------------------
-## Set flag to indicate that the machine can do conversion from
-## long double to integers regardless of accuracy. This flag should be
-## set "yes" for all machines except HP-UX 11.00. For HP-UX 11.00, the
-## compiler has 'floating exception' when converting 'long double' to all
-## integers except 'unsigned long long'. Other HP-UX systems are unknown
-## yet. (1/8/05 - SLU)
-
-AC_MSG_CHECKING([if converting from long double to integers works])
-
-if test ${ac_cv_sizeof_long_double} = 0; then
- hdf5_cv_ldouble_to_integer_works=${hdf5_cv_ldouble_to_integer_works=no}
-else
- AC_CACHE_VAL([hdf5_cv_ldouble_to_integer_works],
- [AC_TRY_RUN([
- int main(void)
- {
- void *align;
- long double ld= 9701917572145405952.00L;
- unsigned char v1;
- short v2;
- unsigned int v3;
- int ret = 0;
-
- align = (void*)malloc(sizeof(long double));
- memcpy(align, &ld, sizeof(long double));
-
- /*For HU-UX11.00, there's floating exception(core dump) when doing some of casting
- *from 'long double' to integers*/
- v1=(unsigned char)(*((long double*)align));
- v2=(short)(*((long double*)align));
- v3=(unsigned int)(*((long double*)align));
-
- done:
- exit(ret);
- }
- ], [hdf5_cv_ldouble_to_integer_works=yes], [hdf5_cv_ldouble_to_integer_works=no],)])
-fi
-
-if test ${hdf5_cv_ldouble_to_integer_works} = "yes"; then
- AC_DEFINE([LDOUBLE_TO_INTEGER_WORKS], [1],
- [Define if your system can convert from long double to integer values.])
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-
-## -----------------------------------------------------------------------
## Set flag to indicate that the machine can handle conversion from
## integers to long double. (This flag should be set "yes" for all
## machines except all SGIs, where some conversions are