summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2015-02-22 10:44:41 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2015-02-22 10:44:41 (GMT)
commitbfc039550751118a400351bad921b63d4bbd274f (patch)
tree7b8252fab5e33e6971ad5bf3373a0b713ce26700 /configure.ac
parentf634105bdb7c494a5ab39291d64c00676c11b476 (diff)
downloadhdf5-bfc039550751118a400351bad921b63d4bbd274f.zip
hdf5-bfc039550751118a400351bad921b63d4bbd274f.tar.gz
hdf5-bfc039550751118a400351bad921b63d4bbd274f.tar.bz2
[svn-r26272] Merge of r26071 from features/autotools_rework
Removes the --with-default-vfd option from configure. This was basically useless and only allowed selecting the stdio VFD. Since this is a demo VFD and not really a production VFD, we decided to retire this option. Fixes: HDFFV-9081 Tested on: h5committest NOTE: platypus cmake fails, but this is not a new error.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 1 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index aff469f..812ea9a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2464,6 +2464,7 @@ if test -n "$PARALLEL"; then
fi
fi
+
## ----------------------------------------------------------------------
## Turn on internal I/O filters by setting macros in header files
## Internal I/O filters are contained entirely within the library and do
@@ -2531,34 +2532,6 @@ if test -n "$FILTERS"; then
done
fi
-## --------------------------------------------------------------------------
-## Should the Default Virtual File Driver be compiled?
-##
-
-AC_MSG_CHECKING([for Default Virtual File Driver definition])
-AC_ARG_WITH([default-vfd],
- [AS_HELP_STRING([--with-default-vfd=driver],
- [Specify default file driver
- [default=sec2]])],,
- withval=sec2)
-
-if test "X$withval" = "Xsec2"; then
- AC_MSG_RESULT([yes])
- default_vfd=yes
- vfd_define=H5FD_SEC2
-elif test "X$withval" = "Xstdio"; then
- AC_MSG_RESULT([yes])
- default_vfd=yes
- vfd_define=H5FD_STDIO
-else
- AC_MSG_RESULT([no])
- default_vfd=no
-fi
-
-if test "X$default_vfd" = "Xyes"; then
- AC_DEFINE_UNQUOTED([DEFAULT_VFD], [$vfd_define],
- [Define the default virtual file driver to compile])
-fi
## ----------------------------------------------------------------------
## Check if Direct I/O driver is enabled by --enable-direct-vfd