summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-09-06 15:15:50 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-09-06 15:15:50 (GMT)
commit145f1ce9e35414e40abf00c139114f69c5e1322d (patch)
treeb2528c469291939818ff0b296ce132138e12bb8e /configure.ac
parentddbc3c841cc71254243e87ede6dd99c403507914 (diff)
downloadhdf5-145f1ce9e35414e40abf00c139114f69c5e1322d.zip
hdf5-145f1ce9e35414e40abf00c139114f69c5e1322d.tar.gz
hdf5-145f1ce9e35414e40abf00c139114f69c5e1322d.tar.bz2
[svn-r24104] HDFFV-8345: add User Defined filters to h5repack.
Reviewed in H5T-61 Tested: local linux - cmake and autotools
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 23 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 386450b..0ae405e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1467,7 +1467,7 @@ case "$host_cpu-$host_vendor-$host_os" in
;;
esac
-## Need to add the AM_ and H5_ into CPFLAGS/CPPFLAGS to make them visible
+## Need to add the AM_ and H5_ into CFLAGS/CPPFLAGS to make them visible
## for configure checks.
## Note: Both will be restored by the end of configure.
CPPFLAGS="$H5_CPPFLAGS $AM_CPPFLAGS $CPPFLAGS"
@@ -3052,6 +3052,27 @@ if test "X$default_vfd" = "Xyes"; then
fi
## ----------------------------------------------------------------------
+## Enable custom plugin default path for library. It requires SHARED support.
+##
+AC_MSG_CHECKING([for Custom Plugin Default Path definition])
+AC_ARG_WITH([default-plugin],
+ [AS_HELP_STRING([--with-default-plugin=location],
+ [Specify default location for plugins
+ [default="/usr/local/hdf5/lib/plugin"]])],,
+ withval="/usr/local/hdf5/lib/plugin")
+
+if test "X$withval" = "X"; then
+ AC_MSG_RESULT([default])
+ default_plugin="/usr/local/hdf5/lib/plugin"
+else
+ AC_MSG_RESULT([$withval])
+ default_plugin=$withval
+fi
+
+AC_DEFINE_UNQUOTED([DEFAULT_PLUGIN], ["$default_plugin"],
+ [Define the default plugins path to compile])
+
+## ----------------------------------------------------------------------
## Check if Direct I/O driver is enabled by --enable-direct-vfd
##
@@ -4516,6 +4537,7 @@ AC_CONFIG_FILES([src/libhdf5.settings
tools/h5jam/testh5jam.sh
tools/h5repack/Makefile
tools/h5repack/h5repack.sh
+ tools/h5repack/h5repack_plugin.sh
tools/h5ls/Makefile
tools/h5copy/Makefile
tools/h5copy/testh5copy.sh