summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-09-10 14:24:34 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-09-10 14:24:34 (GMT)
commit175e82e4843dbf2d6bec7f7121798338f4564379 (patch)
treeb3d93c7c46e8e64984ca6b39db970bf4b5323b40 /configure.ac
parentb0d34310f5ff752c5ab1ef3a0c88229aea32c31f (diff)
downloadhdf5-175e82e4843dbf2d6bec7f7121798338f4564379.zip
hdf5-175e82e4843dbf2d6bec7f7121798338f4564379.tar.gz
hdf5-175e82e4843dbf2d6bec7f7121798338f4564379.tar.bz2
[svn-r24120] HDFFV-8345: plugin test properly checks static-exec result to include test.
Tested: jam
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0ae405e..be0d635 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1046,12 +1046,15 @@ if test "X$STATIC_EXEC" = "Xyes"; then
## Issue a warning if -static flag is not supported.
if test "X$lt_cv_prog_compiler_static_works" = "Xno"; then
echo " warning: -static flag not supported on this system; executable won't statically link shared system libraries."
+ LT_STATIC_EXEC=""
+ else
+ LT_STATIC_EXEC="-all-static"
fi
- LT_STATIC_EXEC="-all-static"
else
echo "no"
LT_STATIC_EXEC=""
fi
+AM_CONDITIONAL([USE_PLUGINS_CONDITIONAL], [test "X$LT_STATIC_EXEC" = X])
AC_SUBST([LT_STATIC_EXEC])